Skip to content

BendingShapeList

Canonical path: NemAll_Python_Reinforcement.BendingShapeList

List for BendingShape objects

__contains__

__contains__(value: BendingShape) -> bool

Check for a value in the list

Parameters:

Returns:

  • bool

    State for value is in the list

__delitem__

__delitem__(value: BendingShape)

Delete a list item

Parameters:

__eq__

__eq__(compare_list: BendingShapeList) -> bool

Compare two lists

Parameters:

Returns:

  • bool

    Lists are equal state

__getitem__

__getitem__(index: int) -> BendingShape

Get a list item

Parameters:

  • index (int) –

    Index of the item

Returns:

__iadd__

__iadd__(eleList: list) -> BendingShapeList

Add a list

Parameters:

  • eleList (list) –

    BendingShape list

Returns:

__init__ overloaded

__init__()

Initialize

__init__(ele: BendingShape)

Constructor with a BendingShape

Parameters:

__init__(eleList: list)

Constructor with a list of BendingShape

Parameters:

  • eleList (list) –

    BendingShape list

__iter__

__iter__() -> Iterator

List iterator

Returns:

  • Iterator

    List iterator

__len__

__len__() -> int

Get the list length

Returns:

  • int

    Length of the list

__repr__

__repr__() -> str

Create a string from the elements of the list

__setitem__

__setitem__(index: int | slice, value: BendingShape)

Set a list item

Parameters:

  • index (int | slice) –

    Index of the item

  • value (BendingShape) –

    Value to item

append

append(value: BendingShape)

Append a list item

Parameters:

extend overloaded

extend(iterable: BendingShapeList)

Add the items from an iterable to the end of the list

Parameters:

extend(eleList: list)

Extend the list

Parameters:

  • eleList (list) –

    BendingShape list

Placeholder