CircularAreaElement
Canonical path: NemAll_Python_Reinforcement.CircularAreaElement
Bases: ReinfElement
, AllplanElement
Implementation of the bar placement element
Methods:
-
GetConcreteCoverContour
–Get the concrete cover from the contour
-
GetConcreteCoverEnd
–Get the concrete cover from the end
-
GetConcreteCoverStart
–Get the concrete cover from the start
-
GetConcreteGrade
–Get the concrete grade
-
GetContourPoints
–Get the contour points
-
GetDiameter
–Get the diameter
-
GetDistance
–Get the distance
-
GetEvenFirstLength
–Get the first length for the even ring number
-
GetEvenOverlapEnd
–Get the overlap length at the end for the even ring number
-
GetEvenOverlapStart
–Get the overlap length at the start for the even ring number
-
GetLengthFactor
–Get the length factor
-
GetMaxBarLength
–Get the maximal bar length
-
GetMaxBarRise
–Get the maximal bar radius
-
GetMinBarLength
–Get the minimal bar length
-
GetMinBarRadius
–Get the minimal bar radius
-
GetOddFirstLength
–Get the first length for the odd ring number
-
GetOddOverlapEnd
–Get the overlap length at the end for the odd ring number
-
GetOddOverlapStart
–Get the overlap length at the start for the even ring number
-
GetOuterAngleEnd
–Get the outer angle at the end
-
GetOuterAngleStart
–Get the outer angle at the start
-
GetOverlapLength
–Get the overlap length
-
GetPlacementRule
–Get the placement rule
-
GetPositionNumber
–Get the position number
-
GetRotationAxis
–Get the rotation axis
-
GetSteelGrade
–Get the steel grade
-
GetinnerAngleEnd
–Get the inner angle at the end
-
GetinnerAngleStart
–Get the inner angle at the start
-
IsPlacePerLinearMeter
–Get the place per linear meter state
-
IsbOverlapEndAsCircle
–Get the overlap state at the end
-
IsbOverlapStartAsCircle
–Get the overlap state at the start
-
SetBarProperties
–Set the bar properties
-
SetLengthFactor
–Set the length factor
-
SetOverlap
–Set the overlap
-
SetPlacePerLinearMeter
–Set the place per linear meter state
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert to string
Attributes:
-
LengthFactor
(float
) –Get the length factor
-
PlacePerLinearMeter
(bool
) –Get the place per linear meter state
PlacePerLinearMeter
property
writable
Get the place per linear meter state
GetConcreteCoverContour
Get the concrete cover from the contour
Returns:
-
float
–Concrete cover from the contour
GetConcreteCoverEnd
Get the concrete cover from the end
Returns:
-
float
–Concrete cover from the end
GetConcreteCoverStart
Get the concrete cover from the start
Returns:
-
float
–Concrete cover from the start
GetConcreteGrade
Get the concrete grade
Returns:
-
int
–Concrete grade (index of the global list starting from 0, -1 = use global value from the Allplan settings)
GetContourPoints
GetContourPoints() -> Polyline3D
GetEvenFirstLength
Get the first length for the even ring number
Returns:
-
float
–First length for the even ring number
GetEvenOverlapEnd
Get the overlap length at the end for the even ring number
Returns:
-
float
–Overlap length at the end for the even ring number
GetEvenOverlapStart
Get the overlap length at the start for the even ring number
Returns:
-
float
–Overlap length at the start for the even ring number
GetMaxBarLength
Get the maximal bar length
Returns:
-
float
–Maximal bar length
GetMaxBarRise
Get the maximal bar radius
Returns:
-
float
–Maximal bar radius
GetMinBarLength
Get the minimal bar length
Returns:
-
float
–Minimal bar length
GetMinBarRadius
Get the minimal bar radius
Returns:
-
float
–Minimal bar radius
GetOddFirstLength
Get the first length for the odd ring number
Returns:
-
float
–First length for the odd ring number
GetOddOverlapEnd
Get the overlap length at the end for the odd ring number
Returns:
-
float
–Overlap length at the end for the odd ring number
GetOddOverlapStart
Get the overlap length at the start for the even ring number
Returns:
-
float
–Overlap length at the start for the odd ring number
GetOuterAngleEnd
Get the outer angle at the end
Returns:
-
float
–Outer angle at the end
GetOuterAngleStart
Get the outer angle at the start
Returns:
-
float
–Outer angle at the start
GetinnerAngleEnd
Get the inner angle at the end
Returns:
-
float
–Inner angle at the end
GetinnerAngleStart
Get the inner angle at the start
Returns:
-
float
–Inner angle at the start
IsPlacePerLinearMeter
Get the place per linear meter state
Returns:
-
bool
–Place per linear meter: true/false
IsbOverlapEndAsCircle
Get the overlap state at the end
Returns:
-
bool
–Overlap length at the end as circle = true, as tangent = false
IsbOverlapStartAsCircle
Get the overlap state at the start
Returns:
-
bool
–Overlap length at the start as circle = true, as tangent = false
SetBarProperties
SetBarProperties(
distance: float,
maxBarLength: float,
minBarLength: float,
placementRule: int,
oddFirstLength: float,
evenFirstLength: float,
minBarRadius: float,
maxBarRise: float,
)
Set the bar properties
Parameters:
-
distance
(float
) –Distance
-
maxBarLength
(float
) –Maximal bar length
-
minBarLength
(float
) –Minimal bar length
-
placementRule
(int
) –Placement rule
-
oddFirstLength
(float
) –First length for the odd ring number
-
evenFirstLength
(float
) –First bar length for the event ring number
-
minBarRadius
(float
) –Minimal bar radius
-
maxBarRise
(float
) –Maximal bar rise
SetLengthFactor
Set the length factor
Parameters:
-
lengthFactor
(float
) –Length factor
SetOverlap
SetOverlap(
oddOverlapStart: float,
evenOverlapStart: float,
bOverlapStartAsCircle: bool,
oddOverlapEnd: float,
evenOverlapEnd: float,
bOverlapEndAsCircle: bool,
overlapLength: float,
)
Set the overlap
Parameters:
-
oddOverlapStart
(float
) –Overlap length at the start for the odd ring number
-
evenOverlapStart
(float
) –Overlap length at the start for the even ring number
-
bOverlapStartAsCircle
(bool
) –Overlap length at the start as circle = true, as tangent = false
-
oddOverlapEnd
(float
) –Overlap length at the end for the odd ring number
-
evenOverlapEnd
(float
) –Overlap length at the end for the even ring number
-
bOverlapEndAsCircle
(bool
) –Overlap length at the end as circle = true, as tangent = false
-
overlapLength
(float
) –Overlap length
SetPlacePerLinearMeter
Set the place per linear meter state
Parameters:
-
bPlacePerLinearMeter
(bool
) –Place per linear meter: true/false
__init__
overloaded
Initialize
__init__(
positionNumber: int,
diameter: float,
steelGrade: int,
concreteGrade: int,
rotationAxis: Line3D,
contourPoints: Polyline3D,
outerAngleStart: float,
outerAngleEnd: float,
innerAngleStart: float,
innerAngleEnd: float,
concreteCoverStart: float,
concreteCoverEnd: float,
concreteCoverContour: float,
)
Constructor
Parameters:
-
positionNumber
(int
) –Position number
-
diameter
(float
) –Diameter
-
steelGrade
(int
) –Steel grade
-
concreteGrade
(int
) –Concrete grade
-
rotationAxis
(Line3D
) –Rotation axis
-
contourPoints
(Polyline3D
) –Contour points
-
outerAngleStart
(float
) –Outer angle at the start
-
outerAngleEnd
(float
) –Outer angle at the end
-
innerAngleStart
(float
) –Inner angle at the start
-
innerAngleEnd
(float
) –Inner angle at the end
-
concreteCoverStart
(float
) –Concrete cover at the start
-
concreteCoverEnd
(float
) –Concrete cover at the end
-
concreteCoverContour
(float
) –Concrete cover of the contour
__init__(element: CircularAreaElement)