HookLengthService
Canonical path: NemAll_Python_Reinforcement.HookLengthService
Service class for the hook length calculation
GetHookLength
GetHookLength(hookAngle: float, hookType: HookType, diameter: float) -> float
Calculate the hook length
Parameters:
-
hookAngle
(float
) –Hook angle
-
hookType
(HookType
) –Hook type
-
diameter
(float
) –Diameter
Returns:
-
float
–Hook length
GetHookLengthPartFromBendingRoller
GetHookLengthPartFromBendingRoller(
hookAngle: float, hookType: HookType, diameter: float
) -> float
Calculate the hook length part from the beginning of the bending roller
Parameters:
-
hookAngle
(float
) –Hook angle
-
hookType
(HookType
) –Hook type
-
diameter
(float
) –Diameter
Returns:
-
float
–Hook length part from the beginning of the bending roller
GetHookLengthPartOfBendingRoller
GetHookLengthPartOfBendingRoller(
hookAngle: float, hookType: HookType, diameter: float
) -> float
Calculate the hook length part of the bending roller
Parameters:
-
hookAngle
(float
) –Hook angle
-
hookType
(HookType
) –Hook type
-
diameter
(float
) –Diameter
Returns:
-
float
–Hook length part of the bending roller
GetStandardAnchorageHookLength
Calculate the standard anchorage hook length
Parameters:
-
diameter
(float
) –Diameter
Returns:
-
float
–Standard anchorage hook length
Placeholder