MeshData
Canonical path: NemAll_Python_Reinforcement.MeshData
Implementation of the mesh data
Methods:
-
CreateLabel
–Create the label
-
Format
–Get the mesh text
-
GetAsBendingDirection
–Get the as in bending direction
-
GetDiameterBendingDirection
–Get the diameter in bending direction
-
GetDimensions
–Get the mesh dimensions
-
GetDistanceBendingDirection
–Get the distance in bending direction
-
GetOverlapBendingDirection
–Get the overlap in bending direction
-
SetType
–Set the mesh type
-
__init__
–Overloaded function. See individual overloads.
Attributes:
-
AsBendingDirection
(float
) –Get the as in bending direction
-
AsCross
(float
) –Get the as in cross direction
-
AsLongitudinal
(float
) –Get the as in longitudinal direction
-
DiameterCross
(float
) –Get the diameter in cross direction
-
DiameterLongitudinal
(float
) –Get the diameter in longitudinal direction
-
DistanceBendingDirection
(float
) –Get the distance in bending direction
-
DistanceCross
(float
) –Get the distance in cross direction
-
DistanceLongitudinal
(float
) –Get the distance in longitudinal direction
-
IsDoubleBarCross
(bool
) –Get the double bar state in cross direction
-
IsDoubleBarLongitudinal
(bool
) –Get the double bar state in longitudinal direction
-
Label
(str
) –Get the mesh label
-
Length
(float
) –Get the mesh length
-
OverlapBendingDirection
(float
) –Get the overlap in bending direction
-
OverlapCross
(float
) –Get the overlap in cross direction
-
OverlapLongitudinal
(float
) –Get the overlap in longitudinal direction
-
Type
(str
) –Get the mesh type
-
Weight
(float
) –Get the mesh weight
-
Width
(float
) –Get the mesh width
DiameterLongitudinal
property
Get the diameter in longitudinal direction
DistanceBendingDirection
property
Get the distance in bending direction
DistanceLongitudinal
property
Get the distance in longitudinal direction
IsDoubleBarLongitudinal
property
Get the double bar state in longitudinal direction
OverlapBendingDirection
property
Get the overlap in bending direction
Format
staticmethod
Get the mesh text
Parameters:
-
type
(str
) –Mesh type
-
length
(float
) –Mesh length
-
width
(float
) –Mesh width
Returns:
-
str
–Mesh text
GetAsBendingDirection
GetAsBendingDirection(bendingDirection: MeshBendingDirection) -> float
Get the as in bending direction
Parameters:
-
bendingDirection
(MeshBendingDirection
) –Bending direction
Returns:
-
float
–As in bending direction
GetDiameterBendingDirection
GetDiameterBendingDirection(
bendingDirection: MeshBendingDirection,
) -> tuple[float, bool]
Get the diameter in bending direction
Parameters:
-
bendingDirection
(MeshBendingDirection
) –Bending direction
Returns:
-
tuple[float, bool]
–tuple(Diameter in bending direction, Double bar state)
GetDimensions
GetDimensions() -> tuple[float, float]
GetDistanceBendingDirection
GetDistanceBendingDirection(bendingDirection: MeshBendingDirection) -> float
Get the distance in bending direction
Parameters:
-
bendingDirection
(MeshBendingDirection
) –Bending direction
Returns:
-
float
–Distance in bending direction
GetOverlapBendingDirection
GetOverlapBendingDirection(bendingDirection: MeshBendingDirection) -> float
Get the overlap in bending direction
Parameters:
-
bendingDirection
(MeshBendingDirection
) –Bending direction
Returns:
-
float
–Overlap in bending direction
__init__
overloaded
Initialize
__init__(
type: str,
length: float,
width: float,
diameterLongitudinal: float,
diameterCross: float,
asLongitudinal: float,
asCross: float,
distanceLongitudinal: float,
distanceCross: float,
bDoubleBarLongitudinal: bool,
bDoubleBarCross: bool,
overlapLongitudinal: float,
overlapCross: float,
weight: float,
)
Constructor
Parameters:
-
type
(str
) –Mesh type
-
length
(float
) –Mesh length
-
width
(float
) –Mesh width
-
diameterLongitudinal
(float
) –Diameter in longitudinal direction
-
diameterCross
(float
) –Diameter in cross direction
-
asLongitudinal
(float
) –As in longitudinal direction
-
asCross
(float
) –As in cross direction
-
distanceLongitudinal
(float
) –Distance in longitudinal direction
-
distanceCross
(float
) –Distance in cross direction
-
bDoubleBarLongitudinal
(bool
) –Double bar in longitudinal direction
-
bDoubleBarCross
(bool
) –Double bar in cross direction
-
overlapLongitudinal
(float
) –Overlap in longitudinal direction
-
overlapCross
(float
) –Overlap in cross direction
-
weight
(float
) –Mesh weight
__init__(element: MeshData)