ReinforcementLabelList
Canonical path: NemAll_Python_Reinforcement.ReinforcementLabelList
__contains__
__contains__(value: ReinforcementLabel) -> bool
Check for a value in the list
Parameters:
-
value
(ReinforcementLabel
) –Value to check
Returns:
-
bool
–State for value is in the list
__delitem__
__delitem__(value: ReinforcementLabel)
__getitem__
__getitem__(index: int) -> ReinforcementLabel
Get a list item
Parameters:
-
index
(int
) –Index of the item
Returns:
-
ReinforcementLabel
–Value for the index
__setitem__
__setitem__(index: int | slice, value: ReinforcementLabel)
Set a list item
Parameters:
-
index
(int | slice
) –Index of the item
-
value
(ReinforcementLabel
) –Value to item
append
append(value: ReinforcementLabel)
extend
extend(iterable: ReinforcementLabelList)
Add the items from an iterable to the end of the list
Parameters:
-
iterable
(ReinforcementLabelList
) –Iterable to add
Placeholder