ReinforcementUtil
Canonical path: NemAll_Python_Reinforcement.ReinforcementUtil
GetNextBarPositionNumber
staticmethod
GetNextBarPositionNumber(doc: DocumentAdapter) -> int
Get the the next bar position number
Returns:
-
int
–Next bar position number
r: doc Document
GetNextMeshPositionNumber
staticmethod
GetNextMeshPositionNumber(doc: DocumentAdapter) -> int
Get the the next mesh position number
Returns:
-
int
–Next mesh position number
r: doc Document
Rearrange
staticmethod
Rearrange(
doc: DocumentAdapter,
fromBarPosition: int = 1,
fromMeshPosition: int = 1,
toBarPosition: int = 99999,
toMeshPosition: int = 99999,
afterBarPosition: int = 1,
aftgerMeshPosition: int = 1,
tolerance: float = 1.0,
rearrangedLock: bool = False,
identicalShapes: bool = False,
identicalPrefix: bool = False,
createUndoStep: bool = True,
)
Rearrange the reinforcement
Parameters:
-
doc
(DocumentAdapter
) –Document
-
fromBarPosition
(int
, default:1
) –Rearrange from bar position
-
fromMeshPosition
(int
, default:1
) –Rearrange from mesh position
-
toBarPosition
(int
, default:99999
) –Rearrange to bar position
-
toMeshPosition
(int
, default:99999
) –Rearrange to mesh position
-
afterBarPosition
(int
, default:1
) –Rearrange after bar position
-
afterMeshPosition
–Rearrange after mesh position
-
tolerance
(float
, default:1.0
) –Tolerance
-
rearrangedLock
(bool
, default:False
) –Rearranged positions are locked state
-
identicalShapes
(bool
, default:False
) –Rearrange identical shapes state
-
identicalPrefix
(bool
, default:False
) –Rearrange identical prefix state
-
createUndoStep
(bool
, default:True
) –Create the undo step state
Placeholder