VecDoubleList
Canonical path: NemAll_Python_Utility.VecDoubleList
Methods:
-
__contains__
–Check for a value in the list
-
__delitem__
–Delete a list item
-
__eq__
–Compare two list
-
__getitem__
–Get a list item
-
__init__
–Overloaded function. See individual overloads.
-
__iter__
–List iterator
-
__len__
–Get the list length
-
__repr__
–Create a string from the values
-
__setitem__
–Set a list item
-
append
–Append a list item
-
extend
–Add the items from an iterable to the end of the list
__contains__
Check for a value in the list
Parameters:
-
value
(float
) –Value to check
Returns:
-
bool
–State for value is in the list
__delitem__
Delete a list item
Parameters:
-
value
(float
) –Value to delete
__eq__
__eq__(compare_list: VecDoubleList) -> bool
Compare two list
Parameters:
-
compare_list
(VecDoubleList
) –List to compare
Returns:
-
bool
–Lists are equal state
__getitem__
Get a list item
Parameters:
-
index
(int
) –Index of the item
Returns:
-
float
–Value for the index
__init__
overloaded
Initialize
Constructor with an initializer list
Parameters:
-
valueList
(list
) –Value list
__setitem__
Set a list item
Parameters:
-
index
(int | slice
) –Index of the item
-
value
(float
) –Value to item
extend
extend(iterable: VecDoubleList)
Add the items from an iterable to the end of the list
Parameters:
-
iterable
(VecDoubleList
) –Iterable to add