VecULongList
Canonical path: NemAll_Python_Utility.VecULongList
__contains__
Check for a value in the list
Parameters:
-
value
(int
) –Value to check
Returns:
-
bool
–State for value is in the list
__eq__
__eq__(compare_list: VecULongList) -> bool
Compare two list
Parameters:
-
compare_list
(VecULongList
) –List to compare
Returns:
-
bool
–Lists are equal state
__getitem__
Get a list item
Parameters:
-
index
(int
) –Index of the item
Returns:
-
int
–Value for the index
__init__
overloaded
Initialize
Constructor with an initializer list
Parameters:
-
valueList
(list
) –Value list
__setitem__
Set a list item
Parameters:
-
index
(int | slice
) –Index of the item
-
value
(int
) –Value to item
extend
extend(iterable: VecULongList)
Add the items from an iterable to the end of the list
Parameters:
-
iterable
(VecULongList
) –Iterable to add
Placeholder