BarShapePointDataList
implementation of the list for the bar shape point data
BarShapePointDataList
Canonical path: StdReinfShapeBuilder.BarShapePointDataList.BarShapePointDataList
Bases: List[Union[Tuple[Point2D, float], Tuple[Point2D, float, float], Tuple[Point2D, float, float, float], Tuple[Point3D, float], Tuple[Point3D, float, float], float]]
the rows can have the following tuple entries
(point: AllplanGeo.Point2D as geometry point, cover: float as concrete cover of the side before the point, bending_roller: float as optional bending roller at the side end, z_coord_bar: float as optional bar coordinate in z direction of the local shape coordinate system)
or
(point: AllplanGeo.Point3D as geometry point, cover: float as concrete cover of the side before the point, bending_roller: float as optional bending roller at the side end)
or
cover: float as concrete cover at the end of the shape