Skip to content

BuildingElementInput

Script for BuildingElementInput

BuildingElementInput

Canonical path: BuildingElementInput.BuildingElementInput

Bases: InputData

Definition of class BuildingElementInput

__init__

__init__(coord_input: CoordinateInput, path: str)

Initialization of class BuildingElementInput

Parameters:

  • coord_input (CoordinateInput) –

    Coordinate input class

  • path (str) –

    Python script path

close_palette

close_palette()

Close the palette

is_visualeditor_running

is_visualeditor_running(
    _power_management: bool, cancel_by_menu_function: bool
) -> bool

check for running visual editor

Parameters:

  • _power_management (bool) –

    checking for power management

  • cancel_by_menu_function (bool) –

    cancel is execute due to menu function start

Returns:

  • bool

    Visual Editor is running

modify_element_property

modify_element_property(page: int, name: str, value: Any)

Modify property of element

Parameters:

  • page (int) –

    the page of the property

  • name (str) –

    the name of the property.

  • value (Any) –

    new value for property.

on_cancel_function

on_cancel_function() -> bool

Cancel the input function

Returns:

  • bool

    True/False for success.

on_control_event

on_control_event(event_id: int)

On control event

Parameters:

  • event_id (int) –

    event id of control.

on_input_undo

on_input_undo() -> bool

Process the input undo event

Returns:

  • bool

    message was processed: True/False

on_mouse_leave

on_mouse_leave()

Handles the mouse leave event

on_preview_draw

on_preview_draw()

Handles the preview draw event

on_shortcut_control_input

on_shortcut_control_input(value: int) -> bool

Handles the input inside the shortcut control

Parameters:

  • value (int) –

    shortcut value

Returns:

  • bool

    message was processed: True/False

on_value_input_control_enter

on_value_input_control_enter() -> bool

Process the enter inside the value input control

Returns:

  • bool

    message was processed: True/False

process_mouse_msg

process_mouse_msg(mouse_msg: int, pnt: Point2D, msg_info: AddMsgInfo) -> bool

Handles the process mouse message event

Parameters:

  • mouse_msg (int) –

    the mouse message.

  • pnt ( ) –

    the input point.

  • msg_info

    additional message info.

Returns:

  • bool

    True/False for success.

reset_param_values

reset_param_values()

Reset to original parameter values from PYP file

save_load_favorite

save_load_favorite(is_save: bool, file_name: str)

Save or load a favorite

Parameters:

  • is_save (bool) –

    True = save, False = load

  • file_name (str) –

    Name of the favorite file

show_palette

show_palette()

show the palette

start_input

start_input(
    file_name: str,
    parameter_data: list[str],
    msg_info: AddMsgInfo | None,
    modify_uuid_list: ModificationElementList,
    geo_matrix: Matrix3D,
    local_placement_matrix: Matrix3D,
    asso_ref_ele: BaseElementAdapter,
    execution_event: ExecutionEvent = AllplanSettings.ExecutionEvent.eCreation,
    modification_matrix: Matrix3D = AllplanGeo.Matrix3D(),
) -> tuple[bool, Any]

Start the input function

Parameters:

  • file_name (str) –

    file name of the pyp file

  • parameter_data (list[str]) –

    parameter data of the selected PythonPart

  • msg_info (AddMsgInfo | None) –

    additional mouse message info

  • modify_uuid_list (ModificationElementList) –

    list with the UUIDs of the modified elements

  • geo_matrix (Matrix3D) –

    placement matrix

  • local_placement_matrix (Matrix3D) –

    local placement matrix

  • asso_ref_ele (BaseElementAdapter) –

    reference element of the associative view

  • execution_event (ExecutionEvent, default: eCreation ) –

    modification event

  • modification_matrix (Matrix3D, default: Matrix3D() ) –

    modification matrix

Returns:

  • tuple[bool, Any]

    (successfully started, started script object)

switch_pythonpart

switch_pythonpart(file_name: str, add_current_to_stack: bool)

Switch to another PythonPart

Parameters:

  • file_name (str) –

    file name of the PythonPart

  • add_current_to_stack (bool) –

    add the current pyp file to the stack

Placeholder