AllplanVersion
Canonical path: NemAll_Python_AllplanSettings.AllplanVersion
Class for extraction of Allplan version information
Methods:
-
MainReleaseName
–Get the Allplan main release name
-
SubReleaseName
–Get the Allplan sub release name
-
Version
–Get the Allplan version as string
-
WindowsReleaseName
–Get the Allplan window release name
MainReleaseName
staticmethod
Get the Allplan main release name Returns: Allplan main release name ('2016', '2017', ...)
SubReleaseName
staticmethod
Get the Allplan sub release name Returns: Allplan sub release name ('2016.0', '2016.1', ...)
Version
staticmethod
Get the Allplan version as string
Returns:
-
str
–Full Allplan version, e.g. 2025.0
Placeholder