AxisProperties
Canonical path: NemAll_Python_ArchElements.AxisProperties
Properties of the axis of a linear architectural component (beam, wall, etc.).
These properties describe the position of the axis in relation to the architectural component.
Methods:
Attributes:
-
Distance
(float
) –Offset distance between the axis and the outer side of the architectural component.
-
Extension
(int
) –Defines, on which side of the axis to generate the architectural component (or its tiers).
-
Modus
(int
) –Get the modus
-
OnTier
(int
) –Get the axis tier
-
Position
(int
) –Position of the axis relative to the architectural component.
Distance
property
writable
Offset distance between the axis and the outer side of the architectural component.
IMPORTANT: The value must be set in the range between <0.0 , component_width>
Extension
property
writable
Defines, on which side of the axis to generate the architectural component (or its tiers).
Assuming the axis origins in (0,0) and points in X+ direction, setting the value to:
- 1 will result in the architectural component being above the axis (on +Y side)
- -1 will result in the architectural component being below the axis (on -Y side)
IMPORTANT: Default value is 0 and must be changed to either 1 or -1!
Position
property
writable
Position of the axis relative to the architectural component.
IMPORTANT: When setting this property, remember to set the Distance accordingly! Otherwise, the architectural component may behave unexpectedly when being modified.