BlockFoundationElement
Canonical path: NemAll_Python_ArchElements.BlockFoundationElement
Bases: ArchElement
, AllplanElement
Implementation of the Block Foundation element
Methods:
-
GetPlacementPoint
–Get the Block Foundation placement point
-
GetProperties
–Get the Block Foundation properties
-
SetCommonProperties
–Set the common properties
-
SetPlacementPoint
–Args:
-
SetProperties
–Set the Block Foundation properties
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert to string
Attributes:
-
PlacementPoint
(Point2D
) –Get the Block Foundation placement point
-
Properties
(BlockFoundationProperties
) –Get the Block Foundation properties
Properties
property
writable
Properties: BlockFoundationProperties
Get the Block Foundation properties
GetPlacementPoint
GetPlacementPoint() -> Point2D
GetProperties
GetProperties() -> BlockFoundationProperties
Get the Block Foundation properties
Returns:
-
BlockFoundationProperties
–Block Foundation properties
SetCommonProperties
SetCommonProperties(commonProp: CommonProperties)
SetProperties
SetProperties(BlockFoundationProp: BlockFoundationProperties)
Set the Block Foundation properties
Parameters:
-
BlockFoundationProp
(BlockFoundationProperties
) –Block Foundation properties
__init__
overloaded
Initialize
__init__(
BlockFoundationProp: BlockFoundationProperties, placementPoint: object
)
Constructor
Parameters:
-
BlockFoundationProp
(BlockFoundationProperties
) –Block Foundation properties
-
placementPoint
(object
) –Placement point
__init__(element: BlockFoundationElement)
Placeholder