Skip to content

BlockFoundationProperties

Canonical path: NemAll_Python_ArchElements.BlockFoundationProperties

Bases: VerticalElementProperties, ArchBaseProperties

Implementation of the BlockFoundation properties

ShapeType property writable

ShapeType: ShapeType

Get the Shape Type

VouteBack property writable

VouteBack: float

Get the Voute Back

VouteFront property writable

VouteFront: float

Get the Voute Front

VouteLeft property writable

VouteLeft: float

Get the Voute Left

VouteRight property writable

VouteRight: float

Get the Voute Right

GetShapeType

GetShapeType() -> ShapeType

Get Shape Type

Returns:

GetVouteBack

GetVouteBack() -> float

Get Voute Back

Returns:

  • float

    Voute Back

GetVouteFront

GetVouteFront() -> float

Get Voute Front

Returns:

  • float

    Voute Front

GetVouteLeft

GetVouteLeft() -> float

Get Voute Left

Returns:

  • float

    Voute Left

GetVouteRight

GetVouteRight() -> float

Get Voute Right

Returns:

  • float

    Voute Right

SetShapeType

SetShapeType(ShapeType: ShapeType)

Set the ShapeType

Parameters:

SetVouteBack

SetVouteBack(VouteBack: float)

Set the VouteBack

Parameters:

  • VouteBack (float) –

    Voute Back

SetVouteFront

SetVouteFront(VouteFront: float)

Set the VouteFront

Parameters:

  • VouteFront (float) –

    Voute Front

SetVouteLeft

SetVouteLeft(VouteLeft: float)

Set the VouteLeft

Parameters:

  • VouteLeft (float) –

    Voute Left

SetVouteRight

SetVouteRight(VouteRight: float)

Set the VouteRight

Parameters:

  • Voutefront

    Voute Right

__init__ overloaded

__init__()

Initialize

__init__(BlockFoundationProp: BlockFoundationProperties)

Copy constructor

Parameters:

  • BlockFoundationnProp

    Properties to copy

Placeholder