SlabFoundationElement
Canonical path: NemAll_Python_ArchElements.SlabFoundationElement
Bases: SlabElement
, ArchElement
, AllplanElement
Implementation of the Slab foundation element
Methods:
-
GetProperties
–Get the Slab found properties
-
SetProperties
–Set the Slab found properties
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert to string
Attributes:
-
Properties
(SlabFoundationProperties
) –Get the Slab found properties
GetProperties
GetProperties() -> SlabFoundationProperties
SetProperties
SetProperties(SlabFoundProp: SlabFoundationProperties)
Set the Slab found properties
Parameters:
-
SlabFoundProp
(SlabFoundationProperties
) –Slab foundation properties
__init__
overloaded
Initialize
__init__(slabFoundProp: SlabFoundationProperties, slabPolygon: Polygon2D)
Constructor
Parameters:
-
slabFoundProp
(SlabFoundationProperties
) –Slab foundation properties
-
slabPolygon
(Polygon2D
) –Slab polygon
__init__(element: SlabFoundationElement)
Placeholder