Skip to content

SlabProperties

Canonical path: NemAll_Python_ArchElements.SlabProperties

Bases: ArchBaseProperties

Implementation of the Slab properties

BackgroundColor property writable

BackgroundColor: int

Get the background color

BitmapName property writable

BitmapName: str

Get the name of the bitmap

CalculationMode property writable

CalculationMode: int

Get the calculation model

CircleDivision property writable

CircleDivision: int

Get the circle division

CommonProperties property writable

CommonProperties: CommonProperties

Get the common properties

FaceStyle property writable

FaceStyle: int

Get the face style ID

Factor property writable

Factor: float

Get the factor

Filling property writable

Filling: int

Get the filling ID

Hatch property writable

Hatch: int

Get the hatch ID

Material property writable

Material: str

Get the material

Name property writable

Name: str

Get the name

Pattern property writable

Pattern: int

Get the pattern ID

Priority property writable

Priority: int

Get the priority

Status property writable

Status: int

Get the Status ID

Surface property writable

Surface: str

Get the surface name and path

SurfaceElementProperties property writable

SurfaceElementProperties: SurfaceElementProperties

Get the surface element properties

TierCount property writable

TierCount: int

Get the tier count

Trade property writable

Trade: int

Get the trade index

VariableTier property writable

VariableTier: int

Get the variable tier

GetAreaPresentationID

GetAreaPresentationID() -> int

Get the ID of the area representation

Returns:

  • int

    ID of the area representation

GetAreaPresentationType

GetAreaPresentationType() -> int

Get the type of the area representation

Returns:

  • int

    Type of the area representation

GetBackgroundColor

GetBackgroundColor() -> int

Get the background color

Returns:

  • int

    Background color

GetBitmapName

GetBitmapName() -> str

Get the name of the bitmap

Returns:

  • str

    Name of the bitmap

GetCalculationMode

GetCalculationMode() -> int

Get the calculation model

Returns:

  • int

    Calculation model

GetCircleDivision

GetCircleDivision() -> int

Get the circle division

Returns:

  • int

    Circle division

GetCommonProperties

GetCommonProperties() -> CommonProperties

Get the common properties

Returns:

GetFaceStyle

GetFaceStyle() -> int

Get the face style ID

Returns:

  • int

    Face style ID

GetFactor

GetFactor() -> float

Get the factor

Returns:

  • float

    Factor

GetFilling

GetFilling() -> int

Get the filling ID

Returns:

  • int

    Filling ID

GetHatch

GetHatch() -> int

Get the hatch ID

Returns:

  • int

    Hatch ID

GetMaterial

GetMaterial() -> str

Get the material

Returns:

  • str

    Material

GetName

GetName() -> str

Get the name

Returns:

  • str

    Name

GetPattern

GetPattern() -> int

Get the pattern ID

Returns:

  • int

    Pattern ID

GetPresentationProperties

GetPresentationProperties() -> object

Get the presentation properties

Returns:

  • object

    Presentation properties

GetPriority

GetPriority() -> int

Get the priority

Returns:

  • int

    Priority

GetSlabTierProperties

GetSlabTierProperties(tierIndex: int) -> SlabTierProperties

Get the wall tier properties

Parameters:

  • tierIndex (int) –

    Tier index

Returns:

GetStatus

GetStatus() -> int

Get the Status ID

Returns:

  • int

    Status ID

GetSurface

GetSurface() -> str

Get the surface name and path

Returns:

  • str

    Surface name and path

GetSurfaceElementProperties

GetSurfaceElementProperties() -> SurfaceElementProperties

Get the surface element properties

Returns:

GetTierCount

GetTierCount() -> int

Get the tier count

Returns:

  • int

    Tier count

GetTrade

GetTrade() -> int

Get the trade index

Returns:

  • int

    Trade index

GetVariableTier

GetVariableTier() -> int

Get the variable tier

Returns:

  • int

    Attribute data set

  • int

    Attribute data set

IsShowAreaElementInGroundView

IsShowAreaElementInGroundView() -> bool

Get the 'Show the area element in the ground view' state

Returns:

  • bool

    Show the area element in the ground view: true/false

RemoveCommonProperties

RemoveCommonProperties()

Remove the common properties

ResetAreaElement

ResetAreaElement()

Reset the area element

ResetBackgroundColor

ResetBackgroundColor()

Reset the background color

SetBackgroundColor

SetBackgroundColor(colorID: int)

Set the background color

Parameters:

  • colorID (int) –

    Background color ID

SetBitmapName

SetBitmapName(bitmapName: str)

Set the name of the bitmap

Parameters:

  • bitmapName (str) –

    Bitmap name

SetCalculationMode

SetCalculationMode(calculationMode: int)

Set the calculation mode

Parameters:

  • calculationMode (int) –

    Calculation mode

SetCircleDivision

SetCircleDivision(circleDivision: int)

Set the circle division

Parameters:

  • circleDivision (int) –

    Circle division

SetCommonProperties

SetCommonProperties(comProp: CommonProperties)

Set the common properties

Parameters:

SetFaceStyle

SetFaceStyle(faceStyleID: int)

Set the face style

Parameters:

  • faceStyleID (int) –

    Face style ID

SetFactor

SetFactor(factor: float)

Set the factor

Parameters:

  • factor (float) –

    Factor

SetFilling

SetFilling(fillingID: int)

Set the filling

Parameters:

  • fillingID (int) –

    Filling ID

SetHatch

SetHatch(hatchID: int)

Set the hatch

Parameters:

  • hatchID (int) –

    Hatch ID

SetMaterial

SetMaterial(material: str)

Set the material

Parameters:

  • material (str) –

    Material

SetName

SetName(name: str)

Set the name

Parameters:

  • name (str) –

    Name

SetPattern

SetPattern(patternID: int)

Set the pattern

Parameters:

  • patternID (int) –

    Pattern ID

SetPriority

SetPriority(priority: int)

Set the priority

Parameters:

  • priority (int) –

    Priority

SetShowAreaElementInGroundView

SetShowAreaElementInGroundView(showInGroundView: bool)

Set the show area element in ground view state

Parameters:

  • showInGroundView (bool) –

    Show the area element in the ground view

SetStatus

SetStatus(statusID: int)

Set the Status ID

Parameters:

  • statusID (int) –

    Status ID

SetSurface

SetSurface(surface: str)

Set the surface

Parameters:

  • surface (str) –

    Surface

SetSurfaceElementProperties

SetSurfaceElementProperties(surfaceElementProp: SurfaceElementProperties)

Set the surface element properties

Parameters:

SetTierCount

SetTierCount(tierCount: int)

Set the tier count

Parameters:

  • tierCount (int) –

    Tier count

SetTrade

SetTrade(value: int)

Set the trade

Parameters:

  • value (int) –

    Trade index

SetVariableTier

SetVariableTier(tierIndex: int)

Set the variable tier

Parameters:

  • tierIndex (int) –

    Tier index

__init__ overloaded

__init__()

Initialize

__init__(slabProp: SlabProperties)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string

Placeholder