Skip to content

StripFoundationElement

Canonical path: NemAll_Python_ArchElements.StripFoundationElement

Bases: ArchElement, AllplanElement

Implementation of the strip foundation element

Properties property writable

Get the strip foundation properties

GetProperties

GetProperties() -> StripFoundationProperties

Get the strip foundation properties

Returns:

SetProperties

SetProperties(stripfoundationProp: StripFoundationProperties)

Set the strip foundation properties

Parameters:

__init__ overloaded

__init__()

Initialize

__init__(stripFoundationProp: StripFoundationProperties, axis: object)

Constructor

Parameters:

__init__(element: StripFoundationElement)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string

Placeholder