Skip to content

StripFoundationProperties

Canonical path: NemAll_Python_ArchElements.StripFoundationProperties

Bases: ArchBaseProperties

Implementation of the strip foundation properties

Axis property writable

Axis: AchseDataT

Get the axis

IsStartNewJoinedStripFoundationGroup property writable

IsStartNewJoinedStripFoundationGroup: bool

Get the state for starting a new joined strip foundation group

All strip foundations in a group are used for to create a continues join between the strip foundations.

LeftHaunch property writable

LeftHaunch: float

Get the Left haunch

ProfileFullName property writable

ProfileFullName: str

Get the full name of the profile

RightHaunch property writable

RightHaunch: float

Get the Right haunch

ShapeType property writable

ShapeType: ShapeType

Get the shape type

StepBounce property writable

StepBounce: float

Get the Step bounce

StepChamferEccentricity property writable

StepChamferEccentricity: float

Get the Step chamfer eccentricity

StepChamferHeight property writable

StepChamferHeight: float

Get the Step chamfer height

StepChamferWidth property writable

StepChamferWidth: float

Get the Step chamfer width

Width property writable

Width: float

Get the width

GetAxis

GetAxis() -> AxisProperties

Get the axis

GetLeftHaunch

GetLeftHaunch() -> float

Get the Left haunch

Returns:

  • float

    width Left haunch

GetProfileFullName

GetProfileFullName() -> str

Get the full name of the profile

Returns:

  • str

    fullName Path and name of the profile

GetRightHaunch

GetRightHaunch() -> float

Get the Right haunch

Returns:

  • float

    width Right haunch

GetShapeType

GetShapeType() -> ShapeType

Get the shape type

Returns:

GetStepBounce

GetStepBounce() -> float

Get the Step bounce

Returns:

  • float

    width Step bounce

GetStepChamferEccentricity

GetStepChamferEccentricity() -> float

Get the Step chamfer eccentricity

Returns:

  • float

    width Step chamfer eccentricity

GetStepChamferHeight

GetStepChamferHeight() -> float

Get the Step chamfer height

Returns:

  • float

    width Step chamfer height

GetStepChamferWidth

GetStepChamferWidth() -> float

Get the Step chamfer width

Returns:

  • float

    width Step chamfer width

GetWidth

GetWidth() -> float

Get the width

Returns:

  • float

    Width

SetAttribute

SetAttribute(attrib: object)

Set the attribute

Parameters:

  • attrib (object) –

    Attribute

SetAxis

SetAxis(axis: AxisProperties)

Set the axis

Parameters:

SetLeftHaunch

SetLeftHaunch(width: float)

Set the Left haunch

Parameters:

  • width (float) –

    Left haunch

SetProfileFullName

SetProfileFullName(fullName: str)

Set the full name of the profile

Parameters:

  • fullName (str) –

    Path and name of the profile

SetRightHaunch

SetRightHaunch(width: float)

Set the Right haunch

Parameters:

  • width (float) –

    Right haunch

SetShapeType

SetShapeType(shapeType: ShapeType)

Set the type of the shape

Parameters:

SetStepBounce

SetStepBounce(width: float)

Set the Step bounce

Parameters:

  • width (float) –

    Step bounce

SetStepChamferEccentricity

SetStepChamferEccentricity(height: float)

Set the Step chamfer eccentricity

Parameters:

  • height (float) –

    Step chamfer eccentricity

SetStepChamferHeight

SetStepChamferHeight(height: float)

Set the Step chamfer height

Parameters:

  • height (float) –

    Step chamfer height

SetStepChamferWidth

SetStepChamferWidth(width: float)

Set the Step chamfer width

Parameters:

  • width (float) –

    Step chamfer width

SetWidth

SetWidth(width: float)

Set the width

Parameters:

  • width (float) –

    Width

__init__ overloaded

__init__()

Initialize

__init__(stripfoundationProp: StripFoundationProperties)

Copy constructor

Parameters:

Placeholder