Skip to content

SurfaceElementProperties

Canonical path: NemAll_Python_ArchElements.SurfaceElementProperties

Implementation of the surface element properties

BitmapID property writable

BitmapID: str

Get bitmap id

BitmapSelected property writable

BitmapSelected: bool

Get the bitmap selected state

FaceStyleID property writable

FaceStyleID: int

Get face style id

FaceStyleSelected property writable

FaceStyleSelected: bool

Get the faceStyle selected state

FillingID property writable

FillingID: int

Get filling id

FillingSelected property writable

FillingSelected: bool

Get the filling selected state

Hatch and pattern can be used in combination with filling.

HatchID property writable

HatchID: int

Get hatch id

HatchSelected property writable

HatchSelected: bool

Get the hatch selected state

PatternID property writable

PatternID: int

Get pattern id

PatternSelected property writable

PatternSelected: bool

Get the pattern selected state

UseAreaInGroundplan property writable

UseAreaInGroundplan: bool

Get if the area should be used in ground plan

__init__ overloaded

__init__()

Initialize

__init__(baseProp: SurfaceElementProperties)

Copy constructor

Parameters:

__repr__

__repr__() -> str

Convert to string

Placeholder