BitmapDefinition
Canonical path: NemAll_Python_BasisElements.BitmapDefinition
Methods:
-
Create
–Create a bitmap definition
-
Dump
–Dump the bitmap definition
-
GetBitmapName
–Get the name
-
GetHeight
–Get bitmap height
-
GetPixel
–Get the color of a specific pixel
-
GetWidth
–Get bitmap width
-
IsHDRI
–Is High Dynamic Range Image
-
LoadBitmap
–Load bitmap
-
setName
–Set the name of the bitmap
Attributes:
-
AbsolutePath
(str
) –Absolute path of the bitmap
-
RelativeName
(str
) –Relative name of the bitmap
Create
staticmethod
Create(bitmapName: str) -> BitmapDefinition
Create a bitmap definition
Returns:
-
BitmapDefinition
–Bitmap definition
Parameters:
-
bitmapName
(str
) –Path and name of the bitmap
GetPixel
Get the color of a specific pixel
Parameters:
-
x
(int
) –horizontal position
-
y
(int
) –vertical position
Returns:
-
int
–Color as ARGB
Placeholder