DimensionLineElement
Canonical path: NemAll_Python_BasisElements.DimensionLineElement
Bases: BasisElement
, AllplanElement
Representation of the dimension line in Allplan.
This class is also a base class for the elevation points.
Methods:
-
GetDimensionPoints
–Get the dimension points
-
GetDirectionVector
–Get the direction vector
-
GetPlacementVector
–Get the placement vector
-
GetProperties
–Get the properties
-
GetSegmentProperties
–Get the segment properties
-
SetDimensionPoints
–Set the dimension points
-
SetDirectionVector
–Set the direction vector
-
SetPlacementVector
–Set the placement vector
-
SetProperties
–Set the properties
-
SetSegmentProperties
–Set the segment properties
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert the list to a string
GetDimensionPoints
GetDimensionPoints() -> Point3DList
GetDirectionVector
GetDirectionVector() -> Vector2D
GetPlacementVector
GetPlacementVector() -> Vector2D
GetProperties
GetProperties() -> DimensionProperties
GetSegmentProperties
GetSegmentProperties() -> DimensionSegmentPropertiesList
SetDimensionPoints
SetDimensionPoints(dimensionPoints: Point3DList)
SetDirectionVector
SetDirectionVector(directionVector: Vector2D)
SetPlacementVector
SetPlacementVector(placementVector: Vector2D)
SetProperties
SetProperties(Prop: DimensionProperties)
SetSegmentProperties
SetSegmentProperties(Prop: DimensionSegmentPropertiesList)
Set the segment properties
Parameters:
-
Segement
–properties
__init__
overloaded
Initialize
__init__(
dimensionPoints: Point3DList,
dimensionPoints: Vector2D,
placementPoint: Vector2D,
directionVector: DimensionProperties,
)
Constructor
Parameters:
-
dimensionPoints
(Point3DList
) –Dimension points
-
placementVector
–Placement vector to the first dimension point
-
directionVector
(DimensionProperties
) –Direction vector
-
dimensionProperties
–Dimension properties
__init__(
dimensionPoints: Point3DList,
arg3: Vector2D,
dimensionPoints: Vector2D,
placementPoint: DimensionProperties,
directionVector: DimensionSegmentPropertiesList,
)
Constructor
Parameters:
-
dimensionPoints
(Point3DList
) –Dimension points
-
placementVector
–Placement vector to the first dimension point
-
directionVector
(DimensionSegmentPropertiesList
) –Direction vector
-
dimensionProperties
–Dimension properties
-
dimensionSegmentProperties
–Dimension segment properties