ElementNodeElement
Canonical path: NemAll_Python_BasisElements.ElementNodeElement
Bases: BasisElement
, AllplanElement
ElementNodeElement class
Methods:
-
GetObjectList
–Get the list of element node objects
-
GetParentID
–Get parent ID
-
SetParentID
–Set the parent element id to this object
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert the list to a string
GetObjectList
Get the list of element node objects
Returns:
-
list
–Element node object list
SetParentID
Set the parent element id to this object
Parameters:
-
ParentID
(type
) –(UUID) sub element id
__init__
overloaded
Initialize
__init__(
commonProp: CommonProperties,
elementNodeId: type,
elementNodeObjectList: list,
)
Constructor
Parameters:
-
commonProp
(CommonProperties
) –Common properties
-
elementGroupProp
–ElementGroup properties
-
elementGroupObjectList
–ElementGroup object list
Placeholder