LibraryElementProperties
Canonical path: NemAll_Python_BasisElements.LibraryElementProperties
Properties of the library element
Methods:
-
GetElement
–Get the element
-
GetElementType
–Get the element type
-
GetGroup
–Get the group
-
GetPath
–Get the path
-
GetPlacementMatrices
–Get the placement matrices
-
GetPlacementMatrix
–Get the placement matrix
-
GetPolyline
–Get the polygon points in case of a line fixture
-
GetProducer
–Get the producer
-
GetSingleFilePath
–Get the Single File Path
-
SetPlacementMatrices
–Set the placement matrices
-
SetPlacementMatrix
–Set the placement matrix
-
SetPolyline
–Set the polygon points in case of a line fixture
-
SetProducer
–Set the producer
-
__init__
–Overloaded function. See individual overloads.
Attributes:
-
PlacementMatrices
(Matrix3DList
) –Get the placement matrices
-
PlacementMatrix
(Matrix3D
) –Get the placement matrix
-
Polyline
(Polyline3D
) –Get the polygon points in case of a line fixture
-
Producer
(str
) –Get the producer
GetElementType
GetElementType() -> LibraryElementType
GetPlacementMatrices
GetPlacementMatrices() -> Matrix3DList
GetPlacementMatrix
GetPlacementMatrix() -> Matrix3D
GetPolyline
GetPolyline() -> Polyline3D
Get the polygon points in case of a line fixture
Returns:
-
Polyline3D
–Polyline points of the line fixture
SetPlacementMatrices
SetPlacementMatrices(placementMatrices: Matrix3DList)
SetPlacementMatrix
SetPlacementMatrix(placementMatrix: Matrix3D)
SetPolyline
SetPolyline(polyline: Polyline3D)
Set the polygon points in case of a line fixture
Parameters:
-
polyline
(Polyline3D
) –Polyline of a line fixture
__init__
overloaded
Initialize
__init__(
fullPathName: str,
elementType: LibraryElementType,
placementMatrix: Matrix3D,
)
Constructor
Parameters:
-
fullPathName
(str
) –Full path and file name
-
elementType
(LibraryElementType
) –Element type
-
placementMatrix
(Matrix3D
) –Placement matrix
__init__(
fullPathName: str,
elementType: LibraryElementType,
placementMatrices: Matrix3DList,
)
Constructor
Parameters:
-
fullPathName
(str
) –Full path and file name
-
elementType
(LibraryElementType
) –Element type
-
placementMatrices
(Matrix3DList
) –Placement matrices
__init__(
path: str,
group: str,
element: str,
elementType: LibraryElementType,
placementMatrix: Matrix3D,
)
Constructor
Parameters:
-
path
(str
) –Path name
-
group
(str
) –Group name
-
element
(str
) –Element name
-
elementType
(LibraryElementType
) –Element type
-
placementMatrix
(Matrix3D
) –Placement matrix
__init__(
path: str,
group: str,
element: str,
elementType: LibraryElementType,
placementMatrices: Matrix3DList,
)
Constructor
Parameters:
-
path
(str
) –Path name
-
group
(str
) –Group name
-
element
(str
) –Element name
-
elementType
(LibraryElementType
) –Element type
-
placementMatrices
(Matrix3DList
) –Placement matrices
__init__(
path: str,
path: str,
group: str,
element: str,
elementType: LibraryElementType,
placementMatrix: Matrix3D,
)
Constructor
Parameters:
-
path
(str
) –Path name
-
group
(str
) –Group name
-
element
(str
) –Element name
-
SingleFilePath
–SingleFilePath
-
elementType
(LibraryElementType
) –Element type
-
placementMatrix
(Matrix3D
) –Placement matrix
__init__(
path: str,
path: str,
group: str,
element: str,
elementType: LibraryElementType,
placementMatrices: Matrix3DList,
)
Constructor
Parameters:
-
path
(str
) –Path name
-
group
(str
) –Group name
-
element
(str
) –Element name
-
SingleFilePath
–SingleFilePath
-
elementType
(LibraryElementType
) –Element type
-
placementMatrices
(Matrix3DList
) –Placement matrices