SectionAlongPathClippingPathViewProperties
Canonical path: NemAll_Python_BasisElements.SectionAlongPathClippingPathViewProperties
Clipping path view properties
TextParameterProperties
property
writable
TextParameterProperties: SectionAlongPathTextParameterProperties
Access text params
Get the SectionAlongPathTextParameterProperties
ConvertDirectionSymbolNumberFromViewModel
Convert icon number used in WPF palette to symbol number used in Allplan for the same graphical representation
Parameters:
-
iPaletteIconNum
(int
) –number of icon from palette (view model)
-
bPaletteIconNum
(bool
) –true if icon number is from palette, false if it is from view model
ConvertDirectionSymbolNumberToViewModel
Convert symbol number used in Allplan to icon number used in WPF palette for the same graphical representation
Returns:
-
int
–icon number used in WPF
GetDirectionSymbolHeightTolerance
staticmethod
Access tolerances
Returns:
-
float
–symbol height tolerance
__init__
overloaded
constructor
Parameters:
-
bInitFromSTW
(bool
, default:False
) –- is structure initialized from standard values
__init__(B: SectionAlongPathClippingPathViewProperties)
Placeholder