Skip to content

SectionFormatProperties

Canonical path: NemAll_Python_BasisElements.SectionFormatProperties

Section format properties

Classes:

Methods:

  • __init__

    Overloaded function. See individual overloads.

Attributes:

CosiderTransparancy property writable

CosiderTransparancy: bool

Get the property for the transparancy

EliminationAngle property writable

EliminationAngle: float

Boundary angle from which the adjacent edges are eliminated

FixtureAsWireframe property writable

FixtureAsWireframe: bool

Get the fixture as wireframe

IsEliminationOn property writable

IsEliminationOn: bool

Whether to eliminate the adjacent edges

SurfaceElements property writable

SurfaceElements: SurfaceElements_Enum

Get the surface elements

SurfaceElements_Enum

Canonical path: NemAll_Python_BasisElements.SectionFormatProperties.SurfaceElements_Enum

Bases: Enum

Type of surface element

Methods:

__getitem__

__getitem__(key: str | int | float) -> SurfaceElements_Enum

get the item for a key

Parameters:

  • key (str | int | float) –

    value key

Returns:

__init__ overloaded

__init__()

Initialize

__init__(bInitFromSTW: bool)

constructor

Parameters:

  • bInitFromSTW (bool) –
    • is structure initialized from standard values
Placeholder