SectionGeneralProperties
Canonical path: NemAll_Python_BasisElements.SectionGeneralProperties
General properties of the UVS
Classes:
-
PlacementPointPosition
–Placement point position
-
State
–Drawing state of the section
Methods:
-
__init__
–Overloaded function. See individual overloads.
Attributes:
-
FilterProperties
(FilterProperties
) –Filtering settings of the UVS
-
FormatProperties
(SectionFormatProperties
) –Format settings of a UVS
-
HiddenSectionLinesProperties
(HiddenSectionLinesProperties
) –Settings regarding hidden section lines in the UVS
-
LabelingProperties
(LabelingProperties
) –Settings regarding labeling the UVS
-
LightProperties
(LightProperties
) –Property for the light properties
-
PlacementAngle
(None
) –Property for the placement angle
-
PlacementPoint
(None
) –Property for the placement point
-
ReferenceScale
(float
) –Property for the reference scale
-
ScaleProperties
(ScaleProperties
) –Property for the scale properties
-
ShowSectionBody
(None
) –Whether to show the section body in the UVS
-
Status
(None
) –Type of the UVS calculation
-
VisibleHiddenEdgesProperties
(VisibleHiddenEdgesProperties
) –Settings regarding hidden and visible lines in the UVS
FormatProperties
property
writable
FormatProperties: SectionFormatProperties
Format settings of a UVS
HiddenSectionLinesProperties
property
writable
HiddenSectionLinesProperties: HiddenSectionLinesProperties
Settings regarding hidden section lines in the UVS
LabelingProperties
property
writable
LabelingProperties: LabelingProperties
Settings regarding labeling the UVS
LightProperties
property
writable
LightProperties: LightProperties
Property for the light properties
ScaleProperties
property
writable
ScaleProperties: ScaleProperties
Property for the scale properties
VisibleHiddenEdgesProperties
property
writable
VisibleHiddenEdgesProperties: VisibleHiddenEdgesProperties
Settings regarding hidden and visible lines in the UVS
PlacementPointPosition
Canonical path: NemAll_Python_BasisElements.SectionGeneralProperties.PlacementPointPosition
Bases: Enum
Placement point position
Methods:
-
__getitem__
–get the item for a key
__getitem__
__getitem__(key: str | int | float) -> PlacementPointPosition
get the item for a key
Parameters:
-
key
(str | int | float
) –value key
Returns:
-
PlacementPointPosition
–value for the key
State
Canonical path: NemAll_Python_BasisElements.SectionGeneralProperties.State
Bases: Enum
Drawing state of the section
Methods:
-
__getitem__
–get the item for a key