SurfaceDefinition
Canonical path: NemAll_Python_BasisElements.SurfaceDefinition
Surface resource definition
Classes:
Methods:
-
CompareData
–compare the surface properties
-
CopyData
–copy the data from an other surface
-
Create
–Create a surface definition
-
Dump
–Dumps content of the resource
-
GetDiffuseFactor
–get the diffuse factor calculated from diffuse color intensity, reflection intensity and the transparency intensity
-
GetHash
–get the hash of the surface definition data
-
GetReflectionFactor
–calculate the reflection factor from transparency and reflection intensity
-
GetScaleU
–get the texture u scale factor
-
GetScaleV
–get the texture v scale factor
-
GetSeasonStatus
–get the surface season flag , true - not all color texture are the same
-
GetSurfaceName
–get the surface name
-
GetTextureID
–get the bitmap id of the texture
-
GetTranslateU
–get the texture u offset
-
GetTranslateV
–get the texture v offset
-
IsDefault
–check whether the surface properties has default values
-
LoadSurfaceData
–load surface properties only
-
PreviewCalculationSkipped
– -
Save
–Create a surface definition
-
SetScale
–set the texture scaling factors -10000 to 10000
-
SetTextureID
–set the bitmapID for one texture
-
SetTranslate
–set the texture offset -INT_MAX to INT_MAX
Attributes:
-
AbsolutePath
(str
) –get the absolute path of the surface, outside from the design path
-
AlphaFromTextureStatus
(bool
) –get the flag for using alpha channel from the color bitmap
-
BumpAmplitude
(float
) –get bump mapping amplitude
-
ColorKey
(ARGB
) –get the color key color
-
ColorKeyStatus
(bool
) –get the flag for using color key
-
ColorKeyTolerance
(int
) –get the color key tolerance 0-255
-
ColorMixingFactor
(int
) –get the color mixing factor, 0 - 100
-
ColorMixingMode
(int
) –get the color mixing mode.
-
DiffuseColor
(ARGB
) –get the diffuse color
-
DiffuseReflectivity
(int
) –get the diffuse color intensity
-
Emission
(float
) –get the color emission intensity
-
MetricStatus
(bool
) –get the flag for texture scale dependency from the object size. true - texture is scaled independently from the object size
-
MultiToneFactor
(float
) –get the coating reflection intensity
-
NormalMapStatus
(bool
) –get the flag for using normal map texture in bump map, otherwise it will be height map
-
NotFound
(bool
) –get the flag for not found surface file
-
ParallaxOffset
(float
) –get the parallax offset
-
ParallaxSamples
(int
) –get parallax samples
-
Reflection
(int
) –get the reflection amplitude
-
Refraction
(float
) –get the IOR
-
RelativeName
(str
) –get the relative path and name of the surface, under the design folder
-
RepeatStatus
(bool
) –get the flag for texture repeating
-
Rotation
(float
) –get the texture rotation angle in degrees
-
Roughness
(float
) –get the roughness amplitude
-
Transparency
(int
) –get the transparency intensity
AbsolutePath
property
writable
get the absolute path of the surface, outside from the design path
AlphaFromTextureStatus
property
writable
get the flag for using alpha channel from the color bitmap
MetricStatus
property
writable
get the flag for texture scale dependency from the object size. true - texture is scaled independently from the object size
NormalMapStatus
property
writable
get the flag for using normal map texture in bump map, otherwise it will be height map
RelativeName
property
writable
get the relative path and name of the surface, under the design folder
SurfaceTextureID
Canonical path: NemAll_Python_BasisElements.SurfaceDefinition.SurfaceTextureID
Bases: Enum
Methods:
-
__getitem__
–get the item for a key
__getitem__
__getitem__(key: str | int | float) -> SurfaceTextureID
get the item for a key
Parameters:
-
key
(str | int | float
) –value key
Returns:
-
SurfaceTextureID
–value for the key
CopyData
CopyData(pSrcSurface: SurfaceDefinition, bCopyName: bool = True)
copy the data from an other surface
GetDiffuseFactor
get the diffuse factor calculated from diffuse color intensity, reflection intensity and the transparency intensity
GetReflectionFactor
calculate the reflection factor from transparency and reflection intensity
GetSeasonStatus
get the surface season flag , true - not all color texture are the same
Save
Save(
surfacePath: str, bitmapDict: Dict[SurfaceTextureID, BitmapDefinition]
) -> bool
Create a surface definition
Returns:
-
bool
–Creation successful state
Parameters:
-
surfacePath
(str
) –Path of the bitmap
-
bitmapDefinitions
–Dict with the bitmap definitions