ClosedArea2D
Canonical path: NemAll_Python_Geometry.ClosedArea2D
Representation class for 2D geometry closed (path bounded) area
Methods:
-
AddInnerCurve
–Add new inner curve
-
Clear
–Clear all the components of this Area
-
GetInnerCurve
–Get the curve of given index
-
GetInnerList
–Get the list of the inner curves
-
GetOuterCurve
–Get the outer curve of this area
-
InnerCount
–Get the count of inner curves
-
IsValid
–Set Check the validity
-
SetOuterCurve
–Set new Outer curve ( bounds )
-
__eq__
–Comparison of closed areas.
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert to string
Attributes:
-
InnerList
(list[Path2D]
) –Get the list of the inner curves
-
OuterCurve
(Path2D
) –Get the outer curve of this area
AddInnerCurve
AddInnerCurve(innerpath: Path2D) -> bool
Add new inner curve
Parameters:
-
innerpath
(Path2D
) –New inner curve
Returns:
-
bool
–true if the operation was successful
GetInnerCurve
GetInnerCurve(index: int) -> Path2D
Get the curve of given index
Parameters:
-
index
(int
) –Index of the inner curve
Returns:
-
Path2D
–const the curve ( Path2D )
GetInnerList
GetInnerList() -> Path2DList
Get the list of the inner curves
Returns:
-
Path2DList
–const a vector that contains the inner curves
GetOuterCurve
GetOuterCurve() -> Path2D
SetOuterCurve
SetOuterCurve(outerpath: Path2D)
__eq__
__eq__(closed_area: ClosedArea2D) -> bool
Comparison of closed areas.
Be careful, this method work without tolerance!
Parameters:
-
closed_area
(ClosedArea2D
) –closed area to be compared.
Returns:
-
bool
–True when closed areas are equal, otherwise false.