ClosedArea3D
Canonical path: NemAll_Python_Geometry.ClosedArea3D
Representation class for 3D geometry area
Methods:
-
AddInnerCurve
–Add new inner curve
-
Clear
–Clear all the components of this Profile
-
GetInnerCurve
–Get the curve of given index
-
GetInnerList
–Get the list of the inner curves
-
GetOuterCurve
–Get the outer curve of this profile
-
GetRefPlacement
–Get axis placement
-
InnerCount
–Get the count of inner curves
-
IsValid
–Set Check the validity
-
SetOuterCurve
–Set new Outer curve ( bounds )
-
SetRefPlacement
–Set axis placement
-
__eq__
–Comparison of closed areas.
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert to string
Attributes:
-
OuterCurve
(Path2D
) –Get the outer curve of this profile
-
RefPlacement
(AxisPlacement3D
) –Get axis placement
AddInnerCurve
AddInnerCurve(innerpath: Path2D) -> bool
Add new inner curve
Parameters:
-
innerpath
(Path2D
) –New inner curve
Returns:
-
bool
–true if the operation was successful
GetInnerCurve
GetInnerCurve(index: int) -> Path2D
Get the curve of given index
Parameters:
-
index
(int
) –Index of the inner curve
Returns:
-
Path2D
–const the curve ( Path2D )
GetInnerList
GetInnerList() -> Path2DList
Get the list of the inner curves
Returns:
-
Path2DList
–const a vector that contains the inner curves
GetOuterCurve
GetOuterCurve() -> Path2D
GetRefPlacement
GetRefPlacement() -> AxisPlacement3D
SetOuterCurve
SetOuterCurve(outerpath: Path2D)
SetRefPlacement
SetRefPlacement(placement: AxisPlacement3D)
__eq__
__eq__(closed_area: ClosedArea3D) -> bool
Comparison of closed areas.
Be careful, this method work without tolerance!
Parameters:
-
closed_area
(ClosedArea3D
) –closed area to be compared.
Returns:
-
bool
–True when closed areas are equal, otherwise false.