Cone3D
Canonical path: NemAll_Python_Geometry.Cone3D
Representation class for 3D Cone.
Methods:
-
GetApex
–Get Apex of the Cone in the local coordinate system
-
GetApexParent
–Get Apex of the Cone in the parent coordinate system
-
GetCenter
–Get Center of the Cone
-
GetHeight
–Get Height of the Cone
-
GetLocalPlacement
–Get Local Placement
-
GetMajorRadius
–Get Major Radius of the Cone
-
GetMinMax
–Get MinMax of the Cone
-
GetMinorRadius
–Get Minor Radius of the Cone
-
GetXAxis
–Get X-Axis of the placement of the Cone
-
GetZAxis
–Get Z - axis of the placement of the Cone
-
IsCircular
–Circularity check for the Cone
-
IsOblique
–Perpendicularity check for the Cone
-
IsValid
–Validity check for the Cone
-
SetApex
–Set Apex in the local coordinate system
-
SetApexParent
–Set Apex in the parent coordinate system
-
SetCenter
–Set center
-
SetHeight
–Set Height of the Cone
-
SetLocalPlacement
–Set Local Placement.
-
SetMajorRadius
–Set Major Radius of the Cone
-
SetMinorRadius
–Set Minor Radius of the Cone
-
__eq__
–Comparison of cones.
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert to string
Attributes:
-
Apex
(Point3D
) –Get Apex of the Cone in the local coordinate system
-
ApexParent
(Point3D
) –Get Apex of the Cone in the parent coordinate system
-
Center
(Point3D
) –Get Center of the Cone
-
Height
(float
) –Get Height of the Cone
-
LocalPlacement
(AxisPlacement3D
) –Get Local Placement
-
MajorRadius
(float
) –Get Major Radius of the Cone
-
MinorRadius
(float
) –Get Minor Radius of the Cone
ApexParent
property
writable
ApexParent: Point3D
Get Apex of the Cone in the parent coordinate system
GetApex
GetApex() -> Point3D
GetApexParent
GetApexParent() -> Point3D
GetLocalPlacement
GetLocalPlacement() -> AxisPlacement3D
GetZAxis
GetZAxis() -> Vector3D
SetApex
SetApex(apex: Point3D)
SetApexParent
SetApexParent(apex: Point3D)
SetLocalPlacement
SetLocalPlacement(placement: AxisPlacement3D)
SetMajorRadius
Set Major Radius of the Cone
Parameters:
-
radius
(float
) –New major radius.
SetMinorRadius
Set Minor Radius of the Cone
Parameters:
-
radius
(float
) –New minor radius.
__eq__
__eq__(cone: Cone3D) -> bool
Comparison of cones.
Be careful, this method work without tolerance!
Parameters:
-
cone
(Cone3D
) –cone to be compared.
Returns:
-
bool
–True when cones are equal, otherwise false.
__init__
overloaded
Initialize
__init__(cone: Cone3D)
__init__(
refPlacement: AxisPlacement3D,
radiusMajor: float,
radiusMinor: float,
apex: Point3D,
)
Constructor.
Height of the Cone is z-coordinate of the Apex.
Parameters:
-
refPlacement
(AxisPlacement3D
) –Local Placement of the Cone.
-
radiusMajor
(float
) –Major radius of the Cone.
-
radiusMinor
(float
) –Minor radius of the Cone.
-
apex
(Point3D
) –Apex of the Cone
__init__(radiusMajor: float, radiusMinor: float, apex: Point3D)
Constructor.
Height of the Cone is z-coordinate of the Apex.
Parameters:
-
radiusMajor
(float
) –Major radius of the Cone.
-
radiusMinor
(float
) –Minor radius of the Cone.
-
apex
(Point3D
) –Apex of the Cone