ConicalSurface3D
Canonical path: NemAll_Python_Geometry.ConicalSurface3D
class for 3D cone surface geometry
Placement
property
writable
Placement: AxisPlacement3D
returns axis placement of the conical surface
sets the position of conical surface
Radius
property
writable
Returns the radius at the placement
Sets the radius at the placement
SemiAngle
property
writable
SemiAngle: Angle
Returns the value of semi angle of conical surface
Sets the value of semi angle of conical surface
Evaluate
Evaluate(angle: float, height: float, local: bool = False) -> Point3D
Evaluate point on surface defined by parameters
Parameters:
-
angle
(float
) –horizontal angle of point according to cone placement (in radians)
-
height
(float
) –vertical height of point according to cone placement
-
local
(bool
, default:False
) –if true, resulting point will be in local coordinates of cone placement
Returns:
-
Point3D
–3D point on surface
Get
Get() -> tuple[AxisPlacement3D, float, Angle]
Get all surface members
Returns:
-
tuple[AxisPlacement3D, float, Angle]
–tuple(placement of conical surface, radius of conical surface in placement, semi angle of conical surface)
GetPlacement
GetPlacement() -> AxisPlacement3D
returns axis placement of the conical surface
Returns:
-
AxisPlacement3D
–placement - point + axis vector + reference direction vector
GetSemiAngle
GetSemiAngle() -> Angle
Set
Set(placement: AxisPlacement3D, radius: float, angle: Angle)
Set all surface members
Parameters:
-
placement
(AxisPlacement3D
) –placement of conical surface
-
radius
(float
) –radius of conical surface in placement
-
angle
(Angle
) –semi angle of conical surface
SetPlacement
SetPlacement(value: AxisPlacement3D)
sets the position of conical surface
Parameters:
-
value
(AxisPlacement3D
) –placement - point + axis vector + reference direction vector
SetRadius
Sets the radius at the placement
Parameters:
-
value
(float
) –radius to be set
SetSemiAngle
SetSemiAngle(value: Angle)
__eq__
__eq__(conical_surface: ConicalSurface3D) -> bool
Comparison of conical surfaces.
Be careful, this method work without tolerance!
Parameters:
-
conical_surface
(ConicalSurface3D
) –conical surface to be compared.
Returns:
-
bool
–True when conical surfaces are equal, otherwise false.
__init__
overloaded
Initialize
__init__(placement: AxisPlacement3D, radius: float, angle: Angle)
Default constructor.
Parameters:
-
placement
(AxisPlacement3D
) –placement of conical surface
-
radius
(float
) –radius at a placement
-
angle
(Angle
) –angle between placement axis and some axis on surface
__init__(surface: ConicalSurface3D)