Cuboid3D
Canonical path: NemAll_Python_Geometry.Cuboid3D
Representation class for 3D cuboid.
Methods:
-
GetBottomFacePolygon
–Get the boundary polygon of bottom face of the cuboid
-
GetGroundPlane
–Get ground plane ( ref point + Z-vector ).
-
GetHeight
–Get height.
-
GetHeightVector
–Get the height vector
-
GetLength
–Get length.
-
GetLengthVector
–Get the length vector
-
GetRefPoint
–Get reference point.
-
GetRelStartPoint
–Get start point in relative coordinates.
-
GetStartPoint
–Get start point in world coordinates.
-
GetTopFacePolygon
–Get the boundary polygon of top face of the cuboid
-
GetVector
–Get given vector.
-
GetWidth
–Get width.
-
GetWidthVector
–Get the width vector
-
Set
–Overloaded function. See individual overloads.
-
SetHeight
–Set height.
-
SetHeightVector
–Set the height vector
-
SetLength
–Set length.
-
SetLengthVector
–Set the length vector
-
SetRefPoint
–Set reference point.
-
SetStartPoint
–Set start point.
-
SetVector
–Set the vector.
-
SetWidth
–Set width.
-
SetWidthVector
–Set the width vector
-
__eq__
–Comparison of cuboid.
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert to string
Attributes:
-
Height
(float
) –Get height.
-
HeightVector
(Vector3D
) –Get the height vector
-
Length
(float
) –Get length.
-
LengthVector
(Vector3D
) –Get the length vector
-
RefPoint
(Point3D
) –Get reference point.
-
StartPoint
(Point3D
) –Get start point in world coordinates.
-
Width
(float
) –Get width.
-
WidthVector
(Vector3D
) –Get the width vector
GetBottomFacePolygon
GetBottomFacePolygon() -> Polygon3D
Get the boundary polygon of bottom face of the cuboid
Returns:
-
Polygon3D
–Bottom face boundary polygon
GetGroundPlane
GetGroundPlane() -> Plane3D
GetHeightVector
GetHeightVector() -> Vector3D
GetLengthVector
GetLengthVector() -> Vector3D
GetRelStartPoint
GetRelStartPoint() -> Point3D
GetStartPoint
GetStartPoint() -> Point3D
GetTopFacePolygon
GetTopFacePolygon() -> Polygon3D
GetVector
GetVector(index: int) -> Vector3D
SetHeight
Set height.
Parameters:
-
height
(float
) –New size of Z-vector ( vector3 ).
SetHeightVector
SetHeightVector(vector: Vector3D)
SetLength
Set length.
Parameters:
-
length
(float
) –New size of X-vector ( vector1 ).
SetLengthVector
SetLengthVector(vector: Vector3D)
SetRefPoint
SetRefPoint(refPoint: Point3D)
SetStartPoint
SetStartPoint(startPoint: Point3D)
SetVector
SetVector(vec: Vector3D, index: int)
SetWidth
Set width.
Parameters:
-
width
(float
) –New size of Y-vector ( vector2 ).
SetWidthVector
SetWidthVector(vector: Vector3D)
__eq__
__eq__(cuboid: Cuboid3D) -> bool
Comparison of cuboid.
Be careful, this method work without tolerance!
Parameters:
-
cuboid
(Cuboid3D
) –cuboid to be compared.
Returns:
-
bool
–True when cuboid are equal, otherwise false.