Cylinder3D
Canonical path: NemAll_Python_Geometry.Cylinder3D
Representation class for 3D Cylinder.
Methods:
-
GetApex
–Get Apex of the Cylinder in the local coordinate system
-
GetApexParent
–Get Apex of the Cylinder in the parent coordinate system
-
GetBottomCenter
–Get bottom center
-
GetCenter
–Get Center of the Cylinder
-
GetHeight
–Get Height of the Cylinder
-
GetLocalPlacement
–Get Local Placement
-
GetMajorRadius
–Get Major Radius of the Cylinder
-
GetMinMax
–Get MinMax of the Cylinder
-
GetMinorRadius
–Get Minor Radius of the Cylinder
-
GetSilhouetteLines
–Get silhouette lines of cylinder
-
GetTopCenter
–Get top center
-
GetXAxis
–Get X-Axis of the placement of the Cylinder
-
GetYAxis
–Get Y-Axis of the placement of the Cylinder
-
GetZAxis
–Get Z - axis of the placement of the Cylinder
-
IsCircular
–Circularity check of the Cylinder
-
IsOblique
–Perpendicularity check of the Cylinder
-
IsValid
–Validity check of the Cylinder
-
SetApex
–Set Apex in the local coordinate system
-
SetApexParent
–Set Apex in the parent coordinate system
-
SetCenter
–Set center
-
SetHeight
–Set Height of the Cylinder
-
SetLocalPlacement
–Overloaded function. See individual overloads.
-
SetMajorRadius
–Set Major Radius of the Cylinder
-
SetMinorRadius
–Set Minor Radius of the Cylinder
-
__eq__
–Comparison of cylinders.
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert to string
Attributes:
-
Apex
(Point3D
) –Get Apex of the Cylinder in the local coordinate system
-
ApexParent
(Point3D
) –Get Apex of the Cylinder in the parent coordinate system
-
Center
(Point3D
) –Get Center of the Cylinder
-
Height
(float
) –Get Height of the Cylinder
-
LocalPlacement
(AxisPlacement3D
) –Get Local Placement
-
MajorRadius
(float
) –Get Major Radius of the Cylinder
-
MinorRadius
(float
) –Get Minor Radius of the Cylinder
ApexParent
property
writable
ApexParent: Point3D
Get Apex of the Cylinder in the parent coordinate system
GetApex
GetApex() -> Point3D
GetApexParent
GetApexParent() -> Point3D
GetBottomCenter
GetBottomCenter() -> Point3D
GetHeight
Get Height of the Cylinder
Returns:
-
float
–Reference to Height of the Cylinder.
GetLocalPlacement
GetLocalPlacement() -> AxisPlacement3D
GetMajorRadius
Get Major Radius of the Cylinder
Returns:
-
float
–Reference to Major Radius.
GetMinMax
GetMinMax() -> MinMax3D
GetMinorRadius
Get Minor Radius of the Cylinder
Returns:
-
float
–Reference to Minor Radius.
GetSilhouetteLines
GetSilhouetteLines(viewMatrix: Matrix3D, bPerspective: bool) -> Line3DList
Get silhouette lines of cylinder
Parameters:
-
viewMatrix
(Matrix3D
) –View matrix
-
bPerspective
(bool
) –Flag if it is central projection or not (true / false)
Returns:
-
Line3DList
–silhouette lines
GetXAxis
GetXAxis() -> Vector3D
GetYAxis
GetYAxis() -> Vector3D
GetZAxis
GetZAxis() -> Vector3D
SetApex
SetApex(apex: Point3D)
SetApexParent
SetApexParent(apex: Point3D)
SetHeight
Set Height of the Cylinder
Parameters:
-
height
(float
) –New height.
SetMajorRadius
Set Major Radius of the Cylinder
Parameters:
-
radius
(float
) –New major radius.
SetMinorRadius
Set Minor Radius of the Cylinder
Parameters:
-
radius
(float
) –New minor radius.
__eq__
__eq__(cylinder: Cylinder3D) -> bool
Comparison of cylinders.
Be careful, this method work without tolerance!
Parameters:
-
cylinder
(Cylinder3D
) –cylinder to be compared.
Returns:
-
bool
–True when cylinders are equal, otherwise false.
__init__
overloaded
Initialize
__init__(cylinder: Cylinder3D)
__init__(
refPlacement: AxisPlacement3D,
radiusMajor: float,
radiusMinor: float,
apex: Point3D,
)
Constructor.
Height of the cylinder is z-coordinate of the Apex.
Parameters:
-
refPlacement
(AxisPlacement3D
) –Local Placement of the cylinder.
-
radiusMajor
(float
) –Major radius of the cylinder.
-
radiusMinor
(float
) –Minor radius of the cylinder.
-
apex
(Point3D
) –Center of the Top Ellipse
__init__(radiusMajor: float, radiusMinor: float, apex: Point3D)
Constructor.
Height of the cylinder is z-coordinate of the Apex.
Parameters:
-
radiusMajor
(float
) –Major radius of the cylinder.
-
radiusMinor
(float
) –Minor radius of the cylinder.
-
apex
(Point3D
) –Center of the Top Ellipse