GeometryEdge
Canonical path: NemAll_Python_Geometry.GeometryEdge
Representation class for the geometry edge
Identification of any edge via point indices, not via point coordinates.
StartIndex
property
writable
Get start index
Index is not checked, you set anything.
Compare
Compare(otherEdge: GeometryEdge) -> ComparisonResult
Compare two edges
Parameters:
-
otherEdge
(GeometryEdge
) –compared edge.
Returns:
-
ComparisonResult
–result of comparison.
Set
Set(edge: Kanten_t)
SetEndIndex
Set end index
Index is not checked, you set anything.
Parameters:
-
index
(int
) –End index.
SetStartIndex
Set start index
Index is not checked, you set anything.
Parameters:
-
index
(int
) –Start index.
__eq__
__eq__(edge: GeometryEdge) -> bool
Equals operator
Parameters:
-
edge
(GeometryEdge
) –other edge
Returns:
-
bool
–true if edges are equal
__init__
overloaded
Initialize
Constructor
Parameters:
-
startIndex
(int
) –Start index of vertex.
-
endIndex
(int
) –End index of vertex.
__init__(edge: GeometryEdge)
__init__(edge: Kanten_t)
Copy constructor from old Allplan structure
Parameters:
-
edge
(Kanten_t
) –Edge which will be copied.
__ne__
__ne__(edge: GeometryEdge) -> bool
Not Equals operator
Parameters:
-
edge
(GeometryEdge
) –other edge
Returns:
-
bool
–true if edges aren't equal
Placeholder