Skip to content

HiddenCalculus

Canonical path: NemAll_Python_Geometry.HiddenCalculus

Hidden calculation service implementation, user part.

This template over HiddenCalculusImpl implements type safe tag storing for hidden calculation. It holds the vector of all used tags and convert them to void* needed in HiddenCalculusImpl.

AddElement

AddElement(
    elementGeometry: object, elenentMaterial: HiddenMaterial, elementTag: int
)

Add element geometry to hidden world.

Parameters:

  • elementGeometry (object) –

    Element geometry.

  • elenentMaterial (HiddenMaterial) –

    Element material.

  • elementTag (int) –

    Tag transferred over hidden calculation from element to line.

Calculate

Calculate()

Runs hidden calculation.

hrow Exception in case of internal error.

Configure

Configure(parameters: HiddenCalculationParameters)

Sets parameters of calculation.

Parameters:

GetLinesCount

GetLinesCount() -> int

Gets total count of lines calculated.

Raises Exception in case of internal error or if Calculate() was not called.

Returns:

  • int

    size_t Lines count.

GetResultLine

GetResultLine(lineIndex: int) -> tuple[Line3D, eHiddenCalculationResult]

GetResultLine

    hrow Exception if index out of range.

Parameters:

  • lineIndex (int) –

    Index of line.

Returns:

GetResultLineMaterial

GetResultLineMaterial(lineIndex: int) -> HiddenMaterial

Gets hidden material of element line is from.

Raises Exception if lineIndex out of range.

Parameters:

  • lineIndex (int) –

    Index of line.

Returns:

GetResultLineTag

GetResultLineTag(lineIndex: int) -> int

Gets (reference to) tag hooked to element line is from.

Parameters:

  • lineIndex (int) –

    Index of line.

Returns:

  • int

    const TagType Reference to tag object.

__init__

__init__()

Initialize

Placeholder