Skip to content

IntersectRayPolyhedronFlag

Canonical path: NemAll_Python_Geometry.IntersectRayPolyhedronFlag

Bases: Enum

Flag determining, what intersection point is to be searched by the IntersectRayPolyhedron function

Attributes:

  • eNegativeIfNoPositive

    Search for intersection points in the direction of the ray. If none is found, search in the opposite

  • eNegativePreferred

    Search for intersection points in the opposite direction of the ray and prefer ones with lowest lambda (prefer -2 over -1)

  • eNegativeVerticalPreferred

    Search only for the intersection with vertical faces (perpendicular to ground view)

  • ePositiveOnly

    Search only for intersection points in the direction of the ray (positive lambda) direction and prefer ones with lambda closest to zero (prefer -1 over -2)

  • eSmallestLmabda

    Search for the intersection point with the smallest lambda (closest to the ray origin)

eNegativeIfNoPositive class-attribute instance-attribute

eNegativeIfNoPositive = 1

Search for intersection points in the direction of the ray. If none is found, search in the opposite

eNegativePreferred class-attribute instance-attribute

eNegativePreferred = 2

Search for intersection points in the opposite direction of the ray and prefer ones with lowest lambda (prefer -2 over -1)

eNegativeVerticalPreferred class-attribute instance-attribute

eNegativeVerticalPreferred = 4

Search only for the intersection with vertical faces (perpendicular to ground view)

ePositiveOnly class-attribute instance-attribute

ePositiveOnly = 0

Search only for intersection points in the direction of the ray (positive lambda) direction and prefer ones with lambda closest to zero (prefer -1 over -2)

eSmallestLmabda class-attribute instance-attribute

eSmallestLmabda = 3

Search for the intersection point with the smallest lambda (closest to the ray origin)

Placeholder