IntersectionRayPolyhedron
Canonical path: NemAll_Python_Geometry.IntersectionRayPolyhedron
Class containing the calculation results of the IntersectRayPolyhedron
function
FaceIdx
property
writable
face index of the face of the best intersection (if found, not unique) beginning from 0
FaceNv
property
writable
FaceNv: Vector3D
normal vector of best-intersected face (if found, not unique)
Lambda
property
writable
Distance from the ray origin to the intersection point (negative if the ray is directed away from the polyhedron)
RetCode
property
writable
0: no inters.,
1: pos. inters. found,
-1: only neg. inters. found
__init__
__init__(element: IntersectionRayPolyhedron)
Placeholder