MinMax3D
Canonical path: NemAll_Python_Geometry.MinMax3D
Representation class for 3D MinMax box.
Methods:
-
Deflate
–Overloaded function. See individual overloads.
-
Get
–Get minimum and maximum point
-
GetCenter
–Get box center point
-
GetMax
–Get maximum point
-
GetMin
–Get minimum point
-
GetSizeX
–Get the size of the box in the X direction
-
GetSizeY
–Get the size of the box in the Y direction
-
GetSizeZ
–Get the size of the box in the Y direction
-
HasSize
–Check if min-max box has some size greater than 'size'
-
Inflate
–Overloaded function. See individual overloads.
-
IsContaining
–Overloaded function. See individual overloads.
-
IsValid
–Test if box is valid
-
Overlaps
–Does box overlap this box
-
Reset
–Set min point to [DBL_MAX,DBL_MAX,DBL_MAX]
-
Set
–Set minimum and maximum point
-
SetMax
–Set maximum point
-
SetMin
–Set minimum point
-
__add__
–Expand MinMax3D box.
-
__eq__
–Comparison of min max values.
-
__iadd__
–Overloaded function. See individual overloads.
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert to string
Attributes:
-
Center
(Point3D
) –Get box center point
-
Max
(Point3D
) –Get maximum point
-
Min
(Point3D
) –Get minimum point
-
SizeX
(float
) –Get the size of the box in the X direction
-
SizeY
(float
) –Get the size of the box in the Y direction
-
SizeZ
(float
) –Get the size of the box in the Y direction
Deflate
overloaded
Deflate in x,y axis concurrently
Parameters:
-
size
(float
) –Deflate in x, y and z axis concurrently
Deflate minmax box
Parameters:
-
x
(float
) –Deflate in X axis
-
y
(float
) –Deflate in Y axis
-
z
(float
) –Deflate in Z axis
Get
GetSizeX
Get the size of the box in the X direction
Returns:
-
float
–delta X value
GetSizeY
Get the size of the box in the Y direction
Returns:
-
float
–delta Y value
GetSizeZ
Get the size of the box in the Y direction
Returns:
-
float
–delta Y value
HasSize
Check if min-max box has some size greater than 'size'
Parameters:
-
size
(float
, default:0.0
) –Size for check
Returns:
-
bool
–yes/no
Inflate
overloaded
Inflate minmax box
Parameters:
-
x
(float
) –Inflate in X axis
-
y
(float
) –Inflate in Y axis
-
z
(float
) –Inflate in Z axis
Inflate in x,y axis concurrently
Parameters:
-
size
(float
) –Inflate in x, y and z axis concurrently
IsContaining
overloaded
IsContaining(box: MinMax3D) -> bool
Is box inside this box
Parameters:
-
box
(MinMax3D
) –Potentially contained box
Returns:
-
bool
–true, if is inside, otherwise false
IsContaining(point: Point3D) -> bool
Is point inside this box
Parameters:
-
point
(Point3D
) –Potentially contained point
Returns:
-
bool
–true, if is inside, otherwise false
Overlaps
Overlaps(box: MinMax3D) -> bool
Does box overlap this box
Parameters:
-
box
(MinMax3D
) –Box
Returns:
-
bool
–true, if boxes overlap, otherwise false
Reset
Set min point to [DBL_MAX,DBL_MAX,DBL_MAX] and max point to [-DBL_MAX,-DBL_MAX,-DBL_MAX]
Set
__add__
__eq__
__eq__(min_max: MinMax3D) -> bool
Comparison of min max values.
Be careful, this method work without tolerance!
Parameters:
-
min_max
(MinMax3D
) –min max to be compared.
Returns:
-
bool
–True when min max values are equal, otherwise false.