Skip to content

DockingPoint

Canonical path: NemAll_Python_IFW_Input.DockingPoint

Implementation of the docking point wrapper

FromString

FromString(dockingPointStr: str)

Create the docking point from a string

Parameters:

  • dockingPointStr (str) –

    Docking point string

GetDockedElements

GetDockedElements() -> VecGUIDList

Get the docked elements

Returns:

GetPoint

GetPoint(doc: DocumentAdapter) -> Point3D

Get the docking point

Parameters:

Returns:

IsValid

IsValid() -> bool

Test for valid docking point

Returns:

  • bool

    Valid state

ToString

ToString() -> str

Convert the docking point to a string

Returns:

  • str

    Docking point string

__init__ overloaded

__init__()

Initialize

__init__(element: DockingPoint)

Copy constructor

Parameters:

Placeholder