HandleService
Canonical path: NemAll_Python_IFW_Input.HandleService
Implementation of the handle service
Methods:
-
AddHandles
–Add the handles
-
DeleteToolTipText
–Delete the tool tip text
-
DrawHandles
–Draw the handles
-
RemoveHandles
–Remove the handles
-
SelectHandle
–Select a handle
-
ShowToolTipText
–Show the tool tip text
-
__init__
–Initialize
AddHandles
AddHandles(
doc: DocumentAdapter,
handlePropList: object,
insertionMat: Matrix3D,
assoRefObj: object,
)
Add the handles
Parameters:
-
doc
(DocumentAdapter
) –Document
-
handlePropList
(object
) –Handle properties list
-
insertionMat
(Matrix3D
) –Transformation matrix
-
assoRefObj
(object
) –Reference element for the drawing inside the associative views
SelectHandle
SelectHandle(
pnt: Point2D,
viewProj: ViewWorldProjection,
eleAdapterTypeUUID: GUID = 0 - 0 - 0 - 0 - 0,
) -> tuple[int, Matrix3D]
Select a handle
Parameters:
-
pnt
(Point2D
) –Cursor point
-
viewProj
(ViewWorldProjection
) –View world projection
-
eleAdapterTypeUUID
(GUID
, default:0 - 0 - 0 - 0 - 0
) –UUID of the handle elements
Returns:
Placeholder