FixtureProperties
Canonical path: NemAll_Python_Palette.FixtureProperties
Methods:
-
GetElement
–Get the element
-
GetGroup
–Get the group
-
GetLastFixturePath
–Get the last fixture path
-
GetPath
–Get the path
-
OpenFixtureDialog
–Open the symbol library dialog
-
__eq__
–Comparison of fixture properties.
-
__init__
–Overloaded function. See individual overloads.
-
__repr__
–Convert the list to a string
Attributes:
-
Element
(None
) –Property access for the element
-
Group
(None
) –Property access for the group
-
Path
(None
) –Property access for the path
-
PathShortcut
(None
) –Property access for the path shortcut
GetLastFixturePath
staticmethod
Get the last fixture path
Returns:
-
str
–Last fixture path
OpenFixtureDialog
staticmethod
Open the symbol library dialog
Returns:
-
str
–result path
Parameters:
-
fixturePath
(str
) –Path to .sym file
__eq__
__eq__(other: FixtureProperties) -> object
Comparison of fixture properties.
Parameters:
-
other
(FixtureProperties
) –Compared fixture properties.
Returns:
-
object
–True when fixture properties are equal, otherwise false.
__init__
overloaded
Initialize
Constructor
Parameters:
-
pathShortcut
(str
) –Path shortcut (Office/Project/Privat)
-
group
(str
) –Group name
-
element
(str
) –Element name
__init__(FixtureProperties: FixtureProperties)
Copy Constructor