Skip to content

DimensioningProperties

Canonical path: NemAll_Python_Precast.DimensioningProperties

AddOuterPoints property writable

AddOuterPoints: bool

Get if the outer points will be addded to the dimension lines

Horizontal property writable

Horizontal: AlignmentProperties

Get the alignment properties for horizontal dimension lines

MaxCountDimLinesBottom property writable

MaxCountDimLinesBottom: int

Get max count of dimension lines on the bottom of a view

MaxCountDimLinesLeft property writable

MaxCountDimLinesLeft: int

Get max count of dimension lines on the left of a view

MaxCountDimLinesRight property writable

MaxCountDimLinesRight: int

Get max count of dimension lines on the right of a view

MaxCountDimLinesTop property writable

MaxCountDimLinesTop: int

Get max count of dimension lines on the top of a view

Rules property writable

Rules: list

Get the rule which should be used for dimension the elements inside the view

Vertical property writable

Get the alignment properties for vertical dimension lines

__init__

__init__()

Initialize

Placeholder