FinishProperties
Canonical path: NemAll_Python_Precast.FinishProperties
Methods:
-
__init__
–Initialize
Attributes:
-
ApplySurfaceElemToFinishSurfaces
(bool
) –Get the Apply surface elements to finish surfaces flag
-
FinishLinesColor
(int
) –Get the Color of the finish lines
-
FinishLinesLayer
(int
) –Get the Layer of the finish lines
-
FinishLinesLineType
(int
) –Get the Line type of the finish lines
-
FinishLinesPen
(int
) –Get the Pen of the finish lines
-
IsFinishLinesColorFromLayer
(bool
) –Get the Is color for finish lines from layer flag
-
IsFinishLinesLineTypeFromLayer
(bool
) –Get the Is tpye of line for finish lines from layer flag
-
IsFinishLinesPenFromLayer
(bool
) –Get the Is pen for finish lines from layer flag
-
ShowCeilingSurfaces
(bool
) –Get the Show ceiling surfaces flag
-
ShowEntireStructOnly
(bool
) –Get the Show show entire struct only flag
-
ShowFloorSurfaces
(bool
) –Get the Show floor surfaces flag
-
ShowVerticalSurfaces
(bool
) –Get the Show vertical surfaces flag
ApplySurfaceElemToFinishSurfaces
property
writable
Get the Apply surface elements to finish surfaces flag
FinishLinesLineType
property
writable
Get the Line type of the finish lines
IsFinishLinesColorFromLayer
property
writable
Get the Is color for finish lines from layer flag
IsFinishLinesLineTypeFromLayer
property
writable
Get the Is tpye of line for finish lines from layer flag
IsFinishLinesPenFromLayer
property
writable
Get the Is pen for finish lines from layer flag
ShowEntireStructOnly
property
writable
Get the Show show entire struct only flag
ShowVerticalSurfaces
property
writable
Get the Show vertical surfaces flag