Skip to content

title: Label Style description: @brief Implementation of the abstract base class LabelStyle


LabelStyle

Canonical path: NemAll_Python_Precast.LabelStyle

Bases: Cell

@brief Implementation of the abstract base class LabelStyle

SetProps

SetProps(labelStyleProps: LabelStyleProperties)

@brief Sets the properties of the labelStyle @param labelStyleProps Props

Parameters:

__init__ overloaded

__init__()

Initialize

__init__(
    cellId: int,
    allowOverlapping: bool,
    labelStyleProps: LabelStyleProperties | None = None,
    conditionTemplate: str = "",
)

@brief Constructor @param cellId @param allowOverlapping @param labelStyleProps @param conditionTemplate

__init__(element: LabelStyle)

Copy constructor

Parameters:

Placeholder