Skip to content

Legend

Canonical path: NemAll_Python_Precast.Legend

Bases: Cell

Implementation of the abstract base class Legend

SetProps

SetProps(legendProps: LegendProperties)

@brief Sets the properties of the legend @param legendProps Props

__init__ overloaded

__init__()

Initialize

__init__(
    cellId: int,
    legendProps: LegendProperties | None = None,
    conditionTemplate: str = "",
)

@brief Constructor @param cellId @param legendProps

Placeholder