Skip to content

Plan

Canonical path: NemAll_Python_Precast.Plan

DrawingFile property writable

DrawingFile: int

Get the Drawing file on which the elementplan should be placed

Position property writable

Position: Point2D

Get the Position where the elementplan should be placed

__init__ overloaded

__init__(doc: DocumentAdapter)

Constructor

Constructor

add_page

add_page(page: Page)

Adds a page to the plan

Parameters:

  • page (Page) –

    to add

create overloaded

create(elemPlan: BaseElementAdapter) -> bool

Creates the elementplan

Parameters:

  • Allplan

    :IFW::ElementAdapter::BaseElementAdapter:-> created elementplan

create(
    elemPlan: BaseElementAdapter, baseElements: BaseElementAdapterList
) -> bool

Creates the elementplan

Parameters:

  • Allplan

    :IFW::ElementAdapter::BaseElementAdapter:-> created elementplan

  • Allplan

    :IFW::ElementAdapter::BaseElementAdapterList:-> elements to create

Placeholder