Skip to content

PrecastElement

Canonical path: NemAll_Python_Precast.PrecastElement

Bases: AllplanElement

Methods:

Attributes:

  • Properties (None) –

    Property for Precast Element Properties

  • deletePython (None) –

    Property to delete Python after elementation

Properties property

Properties: None

Property for Precast Element Properties Value type: PrecastElementProperties

:type: None

deletePython property

deletePython: None

Property to delete Python after elementation Value type: int

:type: None

GetPrecastLayersFromCatalog

GetPrecastLayersFromCatalog(PrecastElementTypeCatalogName: str)

Function to get the Layerconfiguration of the selected PrecastElementType from the catalog args: PrecastElementTypeCatalogName: Name of the PrecastElementType in the catalog

Return type

list(tuple(string, int))

Returns the list of available layers for the selected PrecastElement Return: list(tuple(Name of the PrecastLayer, Materialtype of the PrecastLayer))

:type: None

__init__

__init__(Properties: PrecastElementProperties)

Constructor

Parameters:

  • elementProp

    Element properties

__repr__

__repr__() -> str

Convert to string

Placeholder