Skip to content

PrecastLayerProperties

Canonical path: NemAll_Python_Precast.PrecastLayerProperties

PrecastLayerProperties class

Methods:

Attributes:

CalculateLayerThickness property

CalculateLayerThickness: bool

Property for CalculateLayerThickness Value type: bool

:type: None

LayerName property

LayerName: str

Property for LayerName Value type: str

:type: None

LayerNumber property

LayerNumber: int

Property for LayerNumber Value type: int

:type: None

LayerThickness property

LayerThickness: float

Property for LayerThickness Value type: float

:type: None

Material property

Material: str

Property for Material Value type: str

:type: None

MaterialCatAddressOffset property

MaterialCatAddressOffset: int

Property for MaterialCatAddressOffset Value type: int

:type: None

MaterialType property

MaterialType: int

Property for MaterialType Value type: int

:type: None

SetMaterialCatalogAddressOffset

SetMaterialCatalogAddressOffset(arg2: int, arg3: str) -> int

Set the materialCatAddressOffset

arg2 : MaterialType as integer arg3 : Material as string

Returns:

  • int

    materialCatAddressOffset

__eq__

__eq__(prop: PrecastLayerProperties) -> bool

equal operator

Parameters:

Returns:

  • bool

    true if they are equal, false otherwise

__init__

__init__()

Initialize

__repr__

__repr__() -> str

Convert to string

Placeholder