SectionProperties
Canonical path: NemAll_Python_Precast.SectionProperties
Methods:
-
__init__
–Initialize
Attributes:
-
LimitSectionBodyByElement
(bool
) –Get the Limit section body by element of the section
-
Name
(str
) –Get the Name of the section
-
Prefix
(str
) –Get the Prefix of the section
-
ShowLabel
(bool
) –Get the Show label of the section
-
XDirectionProps
(DirectionProperties
) –Get the X-Direction properties of the section
-
YDirectionProps
(DirectionProperties
) –Get the Y-Direction properties of the section
-
ZDirectionProps
(DirectionProperties
) –Get the Z-Direction properties of the section
LimitSectionBodyByElement
property
writable
Get the Limit section body by element of the section
XDirectionProps
property
writable
XDirectionProps: DirectionProperties
Get the X-Direction properties of the section
YDirectionProps
property
writable
YDirectionProps: DirectionProperties
Get the Y-Direction properties of the section
ZDirectionProps
property
writable
ZDirectionProps: DirectionProperties
Get the Z-Direction properties of the section
Placeholder