Skip to content

TextParameters

Canonical path: NemAll_Python_Precast.TextParameters

BackgroundColorType property writable

BackgroundColorType: int

Get the Type of the background color

BorderColor property writable

BorderColor: int

Get the Border color

BorderLineType property writable

BorderLineType: int

Get the Type of the border line

BorderOffset property writable

BorderOffset: int

Get the Offset of the border

BorderThickness property writable

BorderThickness: int

Get the Border thickness

ColumnAngle property writable

ColumnAngle: float

Get the Column angle

CustomBackgroundColor property writable

CustomBackgroundColor: int

Get the Color of the custom background

FontAngle property writable

FontAngle: float

Get the Font angle

FontColor property writable

FontColor: int

Get the Font color

FontEmphasis property writable

FontEmphasis: int

Get the Font emphasis

FontHeight property writable

FontHeight: float

Get the Font height

FontID property writable

FontID: int

Get the Font ID

FontLayer property writable

FontLayer: int

Get the Font layer

FontWidth property writable

FontWidth: float

Get the Font widht

IsFontColorFromLayer property writable

IsFontColorFromLayer: bool

Get the Is font color from layer flag

IsFontLineTypeFromLayer property writable

IsFontLineTypeFromLayer: bool

Get the Is font line type from layer flag

IsFontPenFromLayer property writable

IsFontPenFromLayer: bool

Get the Is font pen from layer flag

PositionNumberBorderLine property writable

PositionNumberBorderLine: int

Get the Border line position number

RowDistance property writable

RowDistance: float

Get the Row distance

TextPlacementPointType property writable

TextPlacementPointType: TextAlignment

Get the Type of the text placement point

UseBorderAroundTheText property writable

UseBorderAroundTheText: bool

Get the Use border around text flag

UseConstantSizeInLayout property writable

UseConstantSizeInLayout: bool

Get the Use constant size in layout flag

UseCustomTextParameters property writable

UseCustomTextParameters: bool

Get the Use custom text parameters flag

__init__

__init__()

Initialize

Placeholder